ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kathy Zhou <KZ...@cmdservices.com>
Subject RE: install ant 1.6.1 on Unix - solution
Date Tue, 01 Jun 2004 20:52:12 GMT
I had the solution by adding $ANT_HOME/lib in classpath. Here is the answer
I got via internet.
After that, it works.

http://forum.java.sun.com/thread.jsp?forum=7&thread=485924&tstart=75&trange=
15

Thank you, guys.

Kathy

> -----Original Message-----
> From:	Kathy Zhou [SMTP:KZhou@cmdservices.com]
> Sent:	Tuesday, June 01, 2004 4:35 PM
> To:	'Ant Users List'
> Subject:	RE: install ant 1.6.1 on Unix
> 
> Yes, I did javac to compile the classes all the time on that Unix box.
> 
> What I downloaded is apache-ant-1.6.1-bin.zip and unzip it on the server
> and
> set Ant_home and path.
> 
> Also there is Jrun web app server installed on the same box. I may need to
> check this.
> 
> Kathy
> 
> > -----Original Message-----
> > From:	Chappell, Simon P [SMTP:Simon.Chappell@landsend.com]
> > Sent:	Tuesday, June 01, 2004 3:35 PM
> > To:	Ant Users List
> > Subject:	RE: install ant 1.6.1 on Unix
> > 
> > But do you also have javac? Both the JDK and the JRE come with java,
> it's
> > javac that is the differentiator.
> > 
> > Simon
> > 
> > >-----Original Message-----
> > >From: Kathy Zhou [mailto:kzhou@cmdservices.com]
> > >Sent: Tuesday, June 01, 2004 2:27 PM
> > >To: 'Ant Users List'
> > >Subject: RE: install ant 1.6.1 on Unix
> > >
> > >
> > >I typed java -version, the echo is
> > >
> > >java version "1.4.1_03"
> > >Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1_03-b02)
> > >Java HotSpot(TM) Client VM (build 1.4.1_03-b02, mixed mode)    
> > >
> > >Kathy
> > >
> > >-----Original Message-----
> > >From:	Erik Hatcher [SMTP:erik@ehatchersolutions.com]
> > >Sent:	Tuesday, June 01, 2004 3:26 PM
> > >To:	Ant Users List
> > >Subject:	Re: install ant 1.6.1 on Unix
> > >
> > >Do you have a JDK available?  Or just a JRE?
> > >
> > >Try typing 'java' and 'javac' at the command-prompt.
> > >
> > >	Erik
> > >
> > >
> > >On Jun 1, 2004, at 3:06 PM, Kathy Zhou wrote:
> > >
> > >> Matt,
> > >> Thank you for your response.
> > >> I try ant --execdebug -version and got the same error.
> > >> 	java.lang.InstantiationException:  org.apache.tools.ant.Main
> > >> 	>         at java.lang.Class.newInstance0(Class.java:291)
> > >> 	>         at java.lang.Class.newInstance(Class.java:259)
> > >> 	>         at
> > >> org.apache.tools.ant.launch.Launcher.run(Launcher.java:196)
> > >> 	>         at
> > >> org.apache.tools.ant.launch.Launcher.main(Launcher.java:56)
> > >>
> > >> my setting on unix is
> > >>
> > >>
> > >> JAVA_HOME=/usr/j2se
> > >> ANT_HOME=/usr/apache-ant-1.6.1
> > >> PATH=.:/usr/j2se/bin:/usr/apache-ant-1.6.1/bin:/bin:/lib:/usr/sbin: 
> > >> usr/bin:/
> > >> usr/local/bin:/usr/ucb
> > >> export PATH
> > >>
> > >>
> > >> Everything is fine on window. I guess I still missed 
> > >something on Unix
> > >> setting. I did not see anything wrong here, any idea? Thanks.
> > >>
> > >> Kathy
> > >>
> > >>> -----Original Message-----
> > >>> From:	Matt Benson [SMTP:gudnabrsam@yahoo.com]
> > >>> Sent:	Tuesday, June 01, 2004 2:50 PM
> > >>> To:	Ant Users List
> > >>> Subject:	Re: install ant 1.6.1 on Unix
> > >>>
> > >>> Try running
> > >>>
> > >>> ant --execdebug -version
> > >>>
> > >>> This will show you exactly what command is being used
> > >>> to invoke Ant.  That should give you some things to
> > >>> check.
> > >>>
> > >>> HTH,
> > >>> Matt
> > >>>
> > >>> --- Kathy Zhou <KZhou@cmdservices.com> wrote:
> > >>>> I have installed the latest Ant on my window NT
> > >>>> without any problem.
> > >>>>
> > >>>> Then I unzip the apache-ant-1.6.1-bin.zip downloaded
> > >>>> on Unix (SunOS 5.8 with
> > >>>> JDK1.4.1_03) and check the files. Based on
> > >>>> installation instruction, I set
> > >>>> path and ant_home on .profile. Now I got the
> > >>>> following error while I typed
> > >>>> ant -version.
> > >>>>
> > >>>> java.lang.InstantiationException:
> > >>>> org.apache.tools.ant.Main
> > >>>>         at
> > >>>> java.lang.Class.newInstance0(Class.java:291)
> > >>>>         at
> > >>>> java.lang.Class.newInstance(Class.java:259)
> > >>>>         at
> > >>>>
> > >>> org.apache.tools.ant.launch.Launcher.run(Launcher.java:196)
> > >>>>         at
> > >>>>
> > >>> org.apache.tools.ant.launch.Launcher.main(Launcher.java:56)
> > >>>>
> > >>>>
> > >>>> I do not have any crimson.jar or other XML parsers
> > >>>> in JRE/ext  and I did set
> > >>>> classpath for ant as it dose not need.
> > >>>>
> > >>>> Do I need to reboot the Unix box? What else did I
> > >>>> miss? Thank you for your
> > >>>> help.
> > >>>>
> > >>>> Kathy
> > >>>>
> > >>>
> > >>>
> > >>>
> > >>> 	
> > >>> 		
> > >>> __________________________________
> > >>> Do you Yahoo!?
> > >>> Friends.  Fun.  Try the all-new Yahoo! Messenger.
> > >>> http://messenger.yahoo.com/
> > >>>
> > >>> 
> > >---------------------------------------------------------------------
> > >>> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> > >>> For additional commands, e-mail: user-help@ant.apache.org
> > >
> > >
> > >---------------------------------------------------------------------
> > >To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> > >For additional commands, e-mail: user-help@ant.apache.org
> > >
> > >
> > >---------------------------------------------------------------------
> > >To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> > >For additional commands, e-mail: user-help@ant.apache.org
> > >
> > >
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> > For additional commands, e-mail: user-help@ant.apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message