ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan.Mate...@rzf.fin-nrw.de
Subject RE: Re: Problem with Database connections and Classpaths
Date Tue, 08 Jun 2004 14:05:35 GMT
Maybe you should replace 'path' with 'location' for the first three
entries ...


Jan

> -----Original Message-----
> From: Keith Hatton [mailto:khatton@axiomsystems.com]
> Sent: Tuesday, June 08, 2004 4:01 PM
> To: Ant Users List
> Subject: RE: Re: Problem with Database connections and Classpaths
> 
> 
> Hi Joanne,
> 
> Not sure whether this is your problem, but java -jar and java 
> -classpath don't always go together. (The Ant task is just a 
> wrapper for these command lines).
> You might try putting a Class-Path: classes12.zip entry into 
> the manifest of ${utiljar}, put both in the same directory, 
> and see if that works.
> 
> Hope this helps,
> Keith
> 
> 
> -----Original Message-----
> From: Joanne L Corless [mailto:jcorless@csc.com]
> Sent: 04 June 2004 14:10
> To: Ant Users List
> Subject: Re: Re: Problem with Database connections and Classpaths
> 
> 
> 
> Hi Ivan,
> 
> Yes thats the gist of it - However I thought I had passed the 
> classes12.zip
> to <java>
> 
> My build script looks like so ~
> 
>  <path id="run.classpath">
>         <pathelement path="${lib}/xalan.jar"/>
>         <pathelement path="${lib}/xercesImpl.jar"/>
>         <pathelement path="${lib}/xml-apis.jar"/>
>         <pathelement location="${dbUtil}/classes12.zip"/>
>   </path>
> 
>   <!-- Build Targets for compile.bat -->
>   <target name="runUtilities" depends="init" >
>     <!-- Compile the java code from ${jsrc} into ${build} -->
>     <java dir="${dbUtil}" jar="${utiljar}" failonerror="true" 
> fork="true"
>      classpathref="run.classpath">
>          <arg value="-encrypt"/>
>       <arg value="${connectionUser}"/>
>       <arg value="${connectionPassword}"/>
>       <arg value="${connectionString}"/>
>       <arg value="keyconfig.xml"/>
>     </java>
>   </target>
> 
> And when you run it in verbose mode you can actually see the 
> classes12.zip
> file on the classpath - but the utility doesn't seem to want 
> to recognise
> the files
> 
> I have found a work around - if you unzip the classes12.zip 
> and jar them
> into the jar file being run then it works
> 
> Joanne Corless
> 
> ------ Ivan Ivanov <rambiusparkisanius () yahoo ! com> wrote:
> 
> >Hi Joanne,
> >As far I undestand you wrote a class in which you make
> >calls to your oracle db and you invoke it with Ant
> >with <java> task. Am I right? If so you should send
> >classptah attribute to <java> and add oracle jdbc
> >driver in it.
> >--- Joanne L Corless <jcorless@csc.com> wrote:
> >> Hi,
> >>
> >> I am trying to develop a standalone application that
> >> makes a number of
> >> calls to an oracle database.
> >>
> >> However although it build OK when I try to run it
> >> through ant - I get a
> >> ClassNotFoundException.<snip>
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message