ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: Newbie deploy question
Date Fri, 18 Jun 2004 14:20:14 GMT
At 07:48 AM 6/18/2004 +0200, you wrote:
>Hi
>I'm trying to deploy a application using ANT but I don't get it to work.
>I know that I'm doing som general error here, but since it's my first 
>build.xml script I just couldn't figure it out.
>
>My install task looks something like this:
>  <target name="install" depends="dist"
>           description="Installs the application to servlet container.">
>
>     <deploy    url="${manager.url}"
>           username="${manger.username}"
>           password="${manager.password}"
>                     path="/${app.name}"
>                      war="jar:file:/${dir.dist}/${app.name}.war"
>     />
>   </target>

jar:file is used to look for a file inside an archive.  However, you want 
the archive itself.  Also, you should be using 3 slashes such as...

war="file:///${dir.dist}/${app.name}.war"


Jake


>And I get the following error:
>
>BUILD FAILED
>file:/home/johan/development/javaxptest/build.xml:183: 
>java.io.FileNotFoundException: 
>jar:file:/home/johan/development/javaxptest/dist/xptest.war (No such file 
>or directory)
>
>But my script have created a xptest.war file in the directory so I don't 
>know whats wrong.
>
>Is it a permission error or what have I missed?
>
>Please help
>
>Regards, Johan
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message