ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From chandrasekar.ravo...@polaris.co.in
Subject Re: out of memory with javac
Date Thu, 06 May 2004 03:23:48 GMT

Ivan,

All my source files lie flat in one directory, i.e., we do not simulate the
package hierachy in the source file directory. There are 844 files.
I have tried using the WebSphere javac, as well as those provided by
Sun(versions 1.2 and 1.3), but to no avail.

Regards,
CR


                                                                                         
                                                
                      Ivan Ivanov                                                        
                                                
                      <rambiusparkisanius         To:      Ant Users List <user@ant.apache.org>
                                          
                      @yahoo.com>                 cc:      (bcc: chandrasekar.ravoori/Polaris)
                                           
                                                  Subject: Re: out of memory with javac  
                                                
                      05/05/2004 07:20 PM                                                
                                                
                      Please respond to                                                  
                                                
                      "Ant Users List"                                                   
                                                
                                                                                         
                                                
                                                                                         
                                                




Hello CR,
can you say how many java files you work with? Are
they really so many?
As for yor shell command
javac -J-mx1000000000 -d $TEMP_SOURCE *.java,
I think that *.java will take only the java files in
the current dir and not all files in the package
hieararchy and thus the shell command will compile
only a part of the sources. Of course this is not an
answer to your problem. I also saw that you are using
executable="${was4.home}/java/bin/javac"
Can you try without it?

Ivan

--- chandrasekar.ravoori@polaris.co.in wrote:
>
> Hi,
>
> The following is a code snippet from my build file
>    <javac
>                         fork="true"
>                         memoryMaximumSize="1000m"
>
> executable="${was4.home}/java/bin/javac"
>                         tempdir="${basedir}/TEMP"
>                 srcdir="${basedir}/APP/SOURCES"
> destdir="
> ${basedir}/APP/CLASSES" >
>                 <classpath >
>                 <path refid="build.classpath" />
>                 </classpath>
>         </javac>
>
> This task fails with an out-of-memory exception.
> However, the equivalent command on the shell prompt
> works without a hitch -
> javac -J-mx1000000000 -d $TEMP_SOURCE *.java.
> I have even tried the following alternatives
> 1. Running javac within the Ant JVM ( fork = "false"
> )  and setting the
> maximum heap size via ANT_OPTS.
> 2. Running javac using the exec task and specifying
> the heap size as the
> argument(-J-mx2000000000).
>
> Nothing works; I am frankly at my wits' end. Is
> forking the problem here?
> Any help would be much
> appreciated.
>
> Regards,
> CR
>
>
>
>
> > This e-Mail may contain proprietary and
confidential
> information and is sent for the intended
> recipient(s) only.
> If by an addressing or transmission error this mail
> has been misdirected to you, you are requested to
> delete this mail immediately.
> You are also hereby notified that any use, any form
> of reproduction, dissemination, copying, disclosure,
> modification,
> distribution and/or publication of this e-mail
> message, contents or its attachment other than by
> its intended recipient/s is strictly prohibited.
>
> Visit Us at http://www.polaris.co.in
>
> >
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> user-unsubscribe@ant.apache.org
> For additional commands, e-mail:
user-help@ant.apache.org





__________________________________
Do you Yahoo!?
Win a $20,000 Career Makeover at Yahoo! HotJobs
http://hotjobs.sweepstakes.yahoo.com/careermakeover

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org







Mime
View raw message