ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anderson, Kajsa (TLR Corp)" <Kajsa.Ander...@thomson.com>
Subject RE: Invalid byte error when running ANT
Date Fri, 28 May 2004 19:32:33 GMT
>I tried to declare it as HTML entity (&iacute;), but failed (if somebody can
>explain, I'll be really thankfull).

XML doesn't know about HTML entities. The only entities XML knows about (without you telling
it) are &amp;, &gt;, &lt;, &quot;, and &apos;. If you want to use other
entities, you need to define them; something like:

<!DOCTYPE project [
 <!ENTITY iacute "&#237;">
]>

Then you can use <echo file="./file.txt"> Mensajer&iacute;a </echo>, and it
shouldn't complain.

HTH

Kajsa Anderson

-----Original Message-----
From: luis.conelly@ge.com [mailto:luis.conelly@ge.com]
Sent: Friday, May 28, 2004 12:25 PM
To: user@ant.apache.org
Subject: RE: Invalid byte error when running ANT


I tried following and worked fine:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<project name="test" default="default" basedir=".">

    <target name="default">
	<echo file="./file.txt"> Mensajer&#237;a </echo>    
    </target>
</project>

I tried to declare it as HTML entity (&iacute;), but failed (if somebody can
explain, I'll be really thankfull). If you need more info regarding to
entities, please check:

http://www.w3schools.com/html/html_entitiesref.asp

Regards
Luis


-----Original Message-----
From: Samuel Cheung [mailto:SCheung@Novarra.com]
Sent: Friday, May 28, 2004 11:37 AM
To: 'user@ant.apache.org'
Subject: Invalid byte error when running ANT


Hi,

I get the following "Invalid byte 2 of 3-byte UTF-8 sequence." error when
running ANT

Error reading project file
D:\workingMain\j2me4_0_31_4\pvc_pvcs6-11\build.xml: I
nvalid byte 2 of 3-byte UTF-8 sequence.

I narrow down the problem to the follow line, the value of the replace
target contains Spanish character":
<replace file="${buildname}.txt" token="TITLE: Messaging" value="PVC-TITLE:
Mensajería" />

Can you tell me how to resolve that?

Thanks in advance.
Sam

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message