ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Elena Ognovenko" <eogno...@abisoft.spb.ru>
Subject RE: Receiving IO error sending email
Date Thu, 27 May 2004 13:54:43 GMT
I found the following info in ant manual for encodings:

encoding  	Specifies the encoding to use for the content of the email.
Values are mime, uu, plain, or auto. The default value is auto.

And still, changing encodings and even deleting this string from build.xml
doesn't help. I am still getting "IO error sending email" when trying to
send the build.

-----Original Message-----
From: Ivan Ivanov [mailto:rambiusparkisanius@yahoo.com] 
Sent: Thursday, May 27, 2004 5:45 PM
To: Ant Users List
Subject: Re: Receiving IO error sending email

Privet Elena,

I think the problem is that the encoding "uu" is not a
valid encoding for Java Virtual Machine. Encoding
attribute of the <mail> task (as all encodings used in
Java) must be a valid encoding. See [1] for more
information what encodings Java support (this is for
1.4.2; you should find it easy for your java version).


HTH Ivan Ivanov

[1]http://java.sun.com/j2se/1.4.2/docs/guide/intl/encoding.doc.html
--- Elena Ognovenko <eognoven@abisoft.spb.ru> wrote:
> Hello All,
> 
>  
> 
> I am using apache-ant-1.5.2 to compile builds. And I
> always fail to send
> email.
> 
> Here is what I've got for you, hope you will be able
> to grant me some
> brilliant ideas what to do:
> 
>  
> 
> 1. I have build.xml file with the following code for
> sending mails
> 
>  
> 
>             <target name="send-release-mail"
> depends="init">
> 
>                         <delete>
> 
>                                    <fileset dir="."
> 
>                                               
> includes="*.zip"/>
> 
>                         </delete>
> 
>                         <zip
> destfile="${app-path}/release_build.zip"
> 
>                         update="true">
> 
>                                    <fileset dir="."
> 
>                                                
> includes="*.log"
> 
>                                                
> excludes=""
> 
>                                    />               
>      
> 
>                         </zip>
> 
>                         <mail
> from="${release_mail.from}"
> 
>                                   
> tolist="${recipients}"
> 
>                                   
> mailhost="${mail.smtp.host}"
> 
>                                   
> subject="${release_mail.subject}
> bld${build.id}"
> 
>                                   
> messagemimetype="text/plain"
> 
>                                    encoding="uu">
> 
>                                   
> <message>${mail.body}</message>
> 
>                                    <fileset dir="."
> 
>                                               
> includes=" release_build.zip"
> 
>                                    />               
>      
> 
>                         </mail>
> 
>              </target>
> 
>  
> 
> 2. Then, I have build.properties file with the
> following specs:
> 
>  
> 
> mail.smtp.host=<!--my real smtp host--> 
> 
> release_mail.from=release_build@test.com 
> 
> recipients=<!--my real email address-->
> 
>  
> 
> release_mail.subject= release build - 
> 
> mail.body=Check the attached log files for details.
> 
>  
> 
> 3. Running ant in verbose mode gives no errors and
> "BUILD SUCCESSFUL"
> messages.
> 
>  
> 
> While trying to send mail, receive the following:
> 
>  
> 
> C:\mde\ant-build>ant send-release-mail
> 
> Buildfile: build.xml
> 
>  
> 
> init:
> 
>  
> 
> send-release-mail:
> 
>       [zip] Warning: skipping zip archive C:\mde\
> release_build.zip because
> no files were included.
> 
>      [mail] Sending email: MDE release build - 
> bld001
> 
>      [mail] Failed to send email
> 
>  
> 
> BUILD FAILED
> 
> file:C:/mde/ant-build/build.xml:2286: IO error
> sending mail
> 
>  
> 
> Total time: 2 seconds
> 
>  
> 
> (build.xml:2286 is "encoding="uu">" string.)
> 
>  
> 
> What can be wrong with the setup?
> 
>  
> 
> Elena.
> 
>  
> 
>   
> 
> 



	
		
__________________________________
Do you Yahoo!?
Friends.  Fun.  Try the all-new Yahoo! Messenger.
http://messenger.yahoo.com/ 

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message