ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Elena Ognovenko" <eogno...@abisoft.spb.ru>
Subject RE: Receiving IO error sending email
Date Thu, 27 May 2004 13:46:23 GMT
I've just remove these strings from build.xml

                        <delete>
                                 <fileset dir="."
                                 includes="*.zip"/>
                        </delete>

But it won't help. I am getting the same message.

I forgot to mention - on another PC in my network, everything works fine
with this code. Mails can be successfully sent from any PC in my network
except mine.

Maybe I miss some necessary programs?

-----Original Message-----
From: Hartman, Shane [mailto:SHARTMAN@thezenith.com] 
Sent: Thursday, May 27, 2004 5:42 PM
To: 'Ant Users List'
Subject: RE: Receiving IO error sending email

It looks like you may be deleting your zip file before you send it or
referencing the incorrect directory when looking for you zip file.

It looks like you have the <delete> tag at the top referencing "." as the
directory and later in your <mail from> tag you are referencing the same
directory to look for you zip file. 

-----Original Message-----
From: Elena Ognovenko [mailto:eognoven@abisoft.spb.ru] 
Sent: Thursday, May 27, 2004 9:29 AM
To: user@ant.apache.org
Subject: Receiving IO error sending email


Hello All,

 

I am using apache-ant-1.5.2 to compile builds. And I always fail to send
email.

Here is what I've got for you, hope you will be able to grant me some
brilliant ideas what to do:

 

1. I have build.xml file with the following code for sending mails

 

            <target name="send-release-mail" depends="init">

                        <delete>

                                   <fileset dir="."

                                               includes="*.zip"/>

                        </delete>

                        <zip destfile="${app-path}/release_build.zip"

                        update="true">

                                   <fileset dir="."

                                                includes="*.log"

                                                excludes=""

                                   />                     

                        </zip>

                        <mail from="${release_mail.from}"

                                   tolist="${recipients}"

                                   mailhost="${mail.smtp.host}"

                                   subject="${release_mail.subject}
bld${build.id}"

                                   messagemimetype="text/plain"

                                   encoding="uu">

                                   <message>${mail.body}</message>

                                   <fileset dir="."

                                               includes=" release_build.zip"

                                   />                     

                        </mail>

             </target>

 

2. Then, I have build.properties file with the following specs:

 

mail.smtp.host=<!--my real smtp host--> 

release_mail.from=release_build@test.com 

recipients=<!--my real email address-->

 

release_mail.subject= release build - 

mail.body=Check the attached log files for details.

 

3. Running ant in verbose mode gives no errors and "BUILD SUCCESSFUL"
messages.

 

While trying to send mail, receive the following:

 

C:\mde\ant-build>ant send-release-mail

Buildfile: build.xml

 

init:

 

send-release-mail:

      [zip] Warning: skipping zip archive C:\mde\ release_build.zip because
no files were included.

     [mail] Sending email: MDE release build -  bld001

     [mail] Failed to send email

 

BUILD FAILED

file:C:/mde/ant-build/build.xml:2286: IO error sending mail

 

Total time: 2 seconds

 

(build.xml:2286 is "encoding="uu">" string.)

 

What can be wrong with the setup?

 

Elena.

 

  

---------------------------------------------------------------------------
This email and any attachments constitute non-public information for use
only by intended recipient(s) and may contain confidential information.  If
you are not an intended recipient, please notify our Information Security
Officer immediately at (941) 906-5844 and permanently delete the original of
this email and any attachments, as well as any copies or printouts thereof.
The unauthorized use, dissemination, distribution or reproduction of this
email and any attachments is prohibited and may be unlawful.

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message