ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anderson, Kajsa" <Kajsa.Ander...@thomson.com>
Subject RE: FTP problem in Ant 1.5.3
Date Tue, 06 Apr 2004 21:19:41 GMT
>I don´t know how to update Eclipse from Ant 1.5 to 1.6 ..."

In Eclipse, go to Window menu -> Preferences -> Ant -> Runtime.  There will
be a spot where you can enter Ant Home instead of using the version supplied
with Eclipse.  The exact location & format of this option is different in
different versions of Eclipse.  

That said, I still tend to do most of my Ant work from a command line...
though it looks like 3.0-M8 may have some additional Ant support (I noticed
an Ant formatter that I don't recall seeing before); I'll have to check that
out. :)

Kajsa Anderson

-----Original Message-----
From: Jan.Materne@rzf.fin-nrw.de [mailto:Jan.Materne@rzf.fin-nrw.de]
Sent: Tuesday, April 06, 2004 11:21 AM
To: user@ant.apache.org
Subject: RE: FTP problem in Ant 1.5.3


It seems that you need the Commons-Net library [1].
I don´t know how to update Eclipse from Ant 1.5 to 1.6, but I know that
Eclipse 3.0 includes Ant 1.6.0.

Usually I recommend updating to Ant 1.6.1 :-)
but you could test these until some works
- copy the common-net.jar to your ANT\lib directory and use iftp
- update to Ant 1.6.1 (but needs common-net also) 
  --> you´ll have to modify your buildfiles
  --> you´re back on "standard" tasks
- update to Eclipse 3.0 (MS 8 is just released :-)


Jan

[1] Homepage
    http://jakarta.apache.org/commons/net/
[2] Download
    http://jakarta.apache.org/site/binindex.cgi (Release Builds  --> Commons
Net)

-----Original Message-----
From: Rhino [mailto:rhino1@sympatico.ca]
Sent: Tuesday, April 06, 2004 6:10 PM
To: ant-user
Subject: FTP problem in Ant 1.5.3


I'm having a problem with FTP, or more precisely iftp. I hope someone can
help.

I am getting:
BUILD FAILED: java.lang.NoClassDefFoundError:
org/apache/commons/net/ftp/FTPClient

when I run the following Ant task:

<!--==================================================================
Define add-in tasks. 
==================================================================--> 
<taskdef name="iftp" classname="net.ipov.ant.ftp.iFtp"/>
<taskdef name="iftp-get" classname="net.ipov.ant.ftp.GetCommand"/>
<taskdef name="iftp-put" classname="net.ipov.ant.ftp.PutCommand"/>
<taskdef name="iftp-mkdir" classname="net.ipov.ant.ftp.MkdirCommand"/>
<taskdef name="iftp-rmdir" classname="net.ipov.ant.ftp.RmCommand"/>
<!--==================================================================
FTP the jars to the server. 
==================================================================--> 
<target name="upload" description="FTP the Jars to the server">
<echo message="Populating ${server.ftp.dir} directory on server"/> 
<iftp server="${server}" username="${userid}" password="${password}" 
description="Populate jar directory on server" 
binary="yes" 
baseDirRemote="${server.ftp.dir}" 
baseDirLocal="${jar.dir}">
<iftp-put rmtdir="/" binary="yes" description="Populate jar directory">
<fileset dir="${jar.dir}" casesensitive="yes" description="Jar file">
<include name="${TipEditor.jar}"/>
<include name="${EventEditor.jar}"/>
<include name="${SDAC_Common.jar}"/>
</fileset>
</iftp-put> 
</iftp> 
</target> 
I feel sure that this is a basic setup kind of question, probably something
to do with placement of the iftp jar or something like that. I was just
starting to get fluent with Ant a year ago but I haven't touched it since
and have forgotten most of what I knew. 

I seem to recall trying the regular Ant FTP task and having problems with
it, then being advised that the iftp task was better. It worked quite well
at that point but seems to be broken now, probably something to do with the
Eclipse upgrades I've done since then. For what it's worth, my
eclipse\plugins directory contains an org.apache.ant_1.5.3 directory which
in turn contains:
about.html
ant.jar
dbunit.jar
iftp-ant-1.1.2.jar
optional.jar
plugin.properties
plugin.xml

I'm using Eclipse 2.1.3. 

Can anyone tell me what I need to do to get my (i)ftp task working? Also,
can anyone advise me on whether the regular FTP task works better than it
did last year? 

I would be willing to upgrade to Ant 1.6 if that would help but I need to
know what to do. Would I install an org.apache.ant_1.6 in the Eclipse
plugins folder and then delete the 1.5.3 folder to avoid conflicts or is it
okay to leave the 1.5.3 folder there? Sorry for the dumb question but I've
never updated Ant before. 

Rhino
---
rhino1 AT sympatico DOT ca
"If you're getting something for nothing, you're not using your own credit
card."

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message