ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rhino" <rhi...@sympatico.ca>
Subject Re: FTP problem in Ant 1.5.3
Date Tue, 06 Apr 2004 18:03:58 GMT

----- Original Message ----- 
From: <Jan.Materne@rzf.fin-nrw.de>
To: <user@ant.apache.org>
Sent: Tuesday, April 06, 2004 1:19 PM
Subject: RE: FTP problem in Ant 1.5.3


>> This didn't solve my new problem though:
>> [iftp] Error while connecting or logging into FTP Server.
>>
>> The vagueness of this message is very disappointing since it
>> doesn't give me
>> any clue as to what might be wrong.

> If [1] is the right source of your distro there should be some output.

I downloaded commons-net-1.1.0.jar and put it in the ant 1.5.3 plugin
directory of Eclipse, then added it to the Ant classpath. That got rid of
the original problem. However, another post says that Ant 1.5.3 should use
netcomponents.jar, which is apparently an older form of commons-net. But one
of the people who developed iftp says common-net is the one to use. I'm not
sure who to right! I've only tried commons-net so far.

> But maybe you´ll try running with -debug.

Good idea! I had forgotten about the -debug flag. I've been using -v (same
as -verbose) but it's not the same thing is it ;-)

Okay, I've run it again with the -debug flag on. Here's what I get (userid
and password obscured):

Build sequence for target `upload' is [upload]

Complete build sequence is [upload, echo, begin, end, getlogin, jar3, jar2,
jar1, gendocs, manifest2, manifest1, init]

upload:

Adding reference: eclipse.progress.monitor ->
org.eclipse.core.runtime.SubProgressMonitor@696c8b

[echo] Populating /var/sdac directory on server

Adding reference: eclipse.progress.monitor ->
org.eclipse.core.runtime.SubProgressMonitor@1554913

[iftp] Setting Transfer File to Binary?: true

[iftp] iFtp ::

server = www.tonge.ca:21

username = 'XXXX' / password = '****'

binary = true / passive = false

remoteDir = '/var/sdac'

localDir = 'd:\eclipse\workspace\SDAC\jar'

[iftp] Error while connecting or logging into FTP Server.

Build sequence for target `end' is [end]

Complete build sequence is [end, echo, begin, getlogin, jar3, jar2, jar1,
gendocs, manifest2, manifest1, init, upload]

end:

Adding reference: eclipse.progress.monitor ->
org.eclipse.core.runtime.SubProgressMonitor@10bcdd9

BUILD FAILED: Target `none' does not exist in this project.


> And try running the buildfile from command line, not from inside Eclipse.
> So you´ll know whether there is the error.

I'm not sure how to do that. I started a command prompt (I'm in Windows XP)
in the xml directory of my project and tried:
ant -v -debug build.xml

but that didn't work: "'ant' is not recognized as an internal or external
command, operable program or batch file."

I suppose that I need to put the Ant executable in my PATH. Unfortunately, I
don't know the name of the Ant executable or where it is to add it to my
PATH.

> [1]
>
http://cvs.apache.org/viewcvs.cgi/ant/src/main/org/apache/tools/ant/taskdefs
/optional/net/FTP.java?rev=1.21.2.8&only_with_tag=ANT_15_BRANCH&view=markup



>> I noticed that iftp has appended a port number of 21 to the
>> server name.
>> That might might be a problem if port 21 is closed on that
>> machine. Is there
>> any way to override it with a different port number if that becomes
>> necessary? I'll see the server administrator shortly to ask
>> about the port
>> number but knowing the right port number won't help if I
>> don't know how to
>> specify it in the iftp task ;-)

> port 21 is the one for ftp. But you should be able to specify that
> by the port-attribute (ok, Ant´s <ftp> has that - I don´t know the iFtp).

It's very possible that the port number is the real issue here. The server
has a fairly high level of security - msec=4 in Linux Mandrake 9.1 - and
port 21 may be turned off. We usually use SSHWin's Secure File Transfer to
send files to the server. I was using the iftp task successfully last year
to send data to the same server but that was before the security got
increased. The system administrator will be dropping by here in a few
minutes so I'll know more then.

Rhino


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message