ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rhino" <rhi...@sympatico.ca>
Subject Question about jar in Ant 1.6.1
Date Sat, 10 Apr 2004 20:26:06 GMT
I'm getting some unexpected messages in a jar task in Ant 1.6.1 on Windows XP. I'm running
Ant in Eclipse 2.1.3.

This is the relevant fragment of my output, created with -debug and -verbose both turned on:
Create_Help_Jar:

Adding reference: eclipse.progress.monitor

[delete] Deleting: D:\eclipse\workspace\SDAC\jar\SDAC_Help.jar

Adding reference: eclipse.progress.monitor

Could not load a dependent class (com/sun/media/jai/codec/FileSeekableStream) for type image

Could not load a dependent class (com/jcraft/jsch/UserInfo) for type sshexec

Could not load a dependent class (com/jcraft/jsch/UserInfo) for type scp

Could not load a dependent class (org/apache/commons/net/SocketClient) for type rexec

Could not load class (org.apache.tools.ant.tasksdefs.cvslib.CvsVersion) for type cvsversion

Could not load a dependent class (com/starbase/starteam/Item) for type stlist

Could not load a dependent class (org/apache/commons/net/SocketClient) for type telnet

Could not load a dependent class (org/apache/commons/net/ftp/FTP) for type ftp

Could not load a dependent class (jdepend/xmlui/JDepend) for type jdepend

Could not load a dependent class (junit/framework/TestListener) for type junit

Could not load a dependent class (com/starbase/starteam/Item) for type stcheckin

Could not load a dependent class (com/starbase/starteam/Item) for type stcheckout

fileset: Setup scanner in dir D:\eclipse\workspace\SDAC\help with patternSet{ includes: [SdacHelp.hs,
SdacGlossary.xml, SdacHelpIndex.xml, SdacHelpTOC.xml, SdacMap.jhm, sdac.css, sdachelp\**,
sdachelp\common\**, sdachelp\definitions\**, sdachelp\events\**, sdachelp\tips\**] excludes:
[] }

As you can see, there a several messages about missing classes, none of which I'm using in
my program. Strangely enough, the jar task completes successfully despite these messages.
Also, although I have several other jar tasks in the same Ant script, none of them reports
these same messages and all of them complete just fine. 

Can anyone fill me in on why I'm getting these messages and what I need to do to get rid of
them? 

Rhino
---
rhino1 AT sympatico DOT ca
"If you're getting something for nothing, you're not using your own credit card."
Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message