ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rainer Noack" <rai...@noacks.net>
Subject RE: running ant from a UNC path...
Date Thu, 01 Apr 2004 21:07:12 GMT
Hi Rob,
running ant from an UNC path is currently not working due
to java inconsistencies on UNC path representation in 
java.net.URL and java.net.URI.
try 
System.out.println(new File("\\\\myunchost\\myuncpath").toURI());
and 
System.out.println(new File("\\\\myunchost\\myuncpath").toURI().toURL());
I've already created a bugreport for Ant as well as for Java
and will provide a proposed patch for Ant in the next days.

If you need a quick (and dirty) solution, i can send you a trial version of
the fixed ant-launcher.jar.

Regards
Rainer

> -----Original Message-----
> From: Anderson, Rob (Global Trade) [mailto:Rob.Anderson@nike.com] 
> Sent: Thursday, April 01, 2004 8:20 PM
> To: user@ant.apache.org
> Subject: running ant from a UNC path...
> 
> 
> I am having trouble running ant from a UNC path. I get the 
> following error with Ant 1.6.1 installed on a UNC path...
> 
> C:\buildtools>"c:\opt\sun\java\1.4.2_03\bin\jav
> a.exe"  -classpath 
> "\\some_network_server\D\1.6.1\lib\ant-launcher.jar" 
> "-Dant.home= \\some_network_server\D\1.6.1" 
> org.apache.tools.ant.launch.Launcher  -Denv dev -proj ecthelp
> java.lang.ClassNotFoundException: org.apache.tools.ant.Main
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
>         at org.apache.tools.ant.launch.Launcher.run(Launcher.java:195)
>         at org.apache.tools.ant.launch.Launcher.main(Launcher.java:56)
> 
> If I run the same installation from a local path, it works 
> fine. Also, If I take the ant.bat from 1.5.4 and use it with 
> this 1.6.1 installation on the UNC path it works, but startup 
> is very very slow. Also, if I am using the ant.bat from 1.5.4 
> with 1.6.1 and the installation is several directories deeper 
> on a UNC path I get the following error...
> 
> The input line is too long.
> :gotAllArgs
>  was unexpected at this time.
> 
> This error appears to be coming from the lcp.bat script.
> 
> Is anyone else experiencing this same issue? Should I open a 
> bug for it?
> 
> Thanks,
> 
> _________________________________________________________________
> Robert Anderson  Sr. System Engineer  Nike - Global Trade IT  
> (503) 532-6803  d
> 
> "Outside of a dog, a book is probably man's best
> friend; inside of dog, it's too dark to read." -Groucho Marx
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message