ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jack Handy" <jha...@apexsystemsinc.com>
Subject RE: FTP problem in Ant 1.5.3
Date Tue, 06 Apr 2004 16:56:29 GMT
I wanted to talk to you about an Ant position I have available give me call
as soon as you can.

-----Original Message-----
From: Conelly, Luis (GNF, Contractor) [mailto:Luis.Conelly@gnf.com]
Sent: Tuesday, April 06, 2004 12:23 PM
To: Ant Users List
Subject: RE: FTP problem in Ant 1.5.3


Not sure for iFTP, but for regular <ftp> task, this message implies you have
not the right jars.

Since I do not integrate ant to any of my IDEs but executing from command
line, I am not pretty sure if these advices can help you; anyway, here you
are:

For ant 1.5.x you require in your $ANT_HOME/lib
- netcomponents.jar; you can download it from[0]; see [1, 2] for more info

For ant 1.6+, you have to use
- jakarta-oro-2.0.7.jar (download it from [3])
- commons-net.jar (download it from [4])

For ant 1.6+ be aware of following statement (from [5])
<quote>
	Use of the FTP task with Microsoft FTP servers

	To use the FTP task with Microsoft FTP servers, you need CVS HEAD of
commons-net and jakarta-oro 	after 2004-02-01 or a release of commons-net
after 1.1.0 and jakarta-oro after 2.0.8.
</quote>

	Regards

	Luis


[0] http://www.nebulais.com/osstandards/current/resources.html
[1] http://marc.theaimsgroup.com/?l=ant-user&m=107394460209704&w=2
[2] http://marc.theaimsgroup.com/?l=ant-user&m=107157965104966&w=2
[3] http://jakarta.apache.org/oro/
[4] http://jakarta.apache.org/commons/net/index.html
[5] http://ant.apache.org/manual/OptionalTasks/ftp.html

-----Original Message-----
From: Rhino [mailto:rhino1@sympatico.ca]
Sent: Tuesday, April 06, 2004 11:10 AM
To: ant-user
Subject: FTP problem in Ant 1.5.3


I'm having a problem with FTP, or more precisely iftp. I hope someone can
help.

I am getting:
BUILD FAILED: java.lang.NoClassDefFoundError:
org/apache/commons/net/ftp/FTPClient

when I run the following Ant task:

<!--==================================================================
Define add-in tasks.
==================================================================-->
<taskdef name="iftp" classname="net.ipov.ant.ftp.iFtp"/>
<taskdef name="iftp-get" classname="net.ipov.ant.ftp.GetCommand"/>
<taskdef name="iftp-put" classname="net.ipov.ant.ftp.PutCommand"/>
<taskdef name="iftp-mkdir" classname="net.ipov.ant.ftp.MkdirCommand"/>
<taskdef name="iftp-rmdir" classname="net.ipov.ant.ftp.RmCommand"/>
<!--==================================================================
FTP the jars to the server.
==================================================================-->
<target name="upload" description="FTP the Jars to the server">
<echo message="Populating ${server.ftp.dir} directory on server"/>
<iftp server="${server}" username="${userid}" password="${password}"
description="Populate jar directory on server"
binary="yes"
baseDirRemote="${server.ftp.dir}"
baseDirLocal="${jar.dir}">
<iftp-put rmtdir="/" binary="yes" description="Populate jar directory">
<fileset dir="${jar.dir}" casesensitive="yes" description="Jar file">
<include name="${TipEditor.jar}"/>
<include name="${EventEditor.jar}"/>
<include name="${SDAC_Common.jar}"/>
</fileset>
</iftp-put>
</iftp>
</target>
I feel sure that this is a basic setup kind of question, probably something
to do with placement of the iftp jar or something like that. I was just
starting to get fluent with Ant a year ago but I haven't touched it since
and have forgotten most of what I knew.

I seem to recall trying the regular Ant FTP task and having problems with
it, then being advised that the iftp task was better. It worked quite well
at that point but seems to be broken now, probably something to do with the
Eclipse upgrades I've done since then. For what it's worth, my
eclipse\plugins directory contains an org.apache.ant_1.5.3 directory which
in turn contains:
about.html
ant.jar
dbunit.jar
iftp-ant-1.1.2.jar
optional.jar
plugin.properties
plugin.xml

I'm using Eclipse 2.1.3.

Can anyone tell me what I need to do to get my (i)ftp task working? Also,
can anyone advise me on whether the regular FTP task works better than it
did last year?

I would be willing to upgrade to Ant 1.6 if that would help but I need to
know what to do. Would I install an org.apache.ant_1.6 in the Eclipse
plugins folder and then delete the 1.5.3 folder to avoid conflicts or is it
okay to leave the 1.5.3 folder there? Sorry for the dumb question but I've
never updated Ant before.

Rhino
---
rhino1 AT sympatico DOT ca
"If you're getting something for nothing, you're not using your own credit
card."


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message