ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Hatton" <khat...@axiomsystems.com>
Subject RE: Ant 1.6 with Weblogic 8.1
Date Thu, 04 Mar 2004 15:36:47 GMT
Hi Fintan,
 
I'm not sure about WLS 8.1 specifically, but previous versions of WLS have included an Ant
version in their distribution and I guess this may well be the source of the problem (I guess
ant.Launcher is expecting an Ant 1.6 ant.Main but finding a 1.5.x ant.Main from weblogic.jar
instead).
 
So...
 
- You might try copying weblogic.jar *only* to some other location and including that in your
classpath (I'm assuming you might be pointing to a full WLS installation, and weblogic.jar
automagically includes other jars by virtue of its Manifest, at least in version 7).
- You might try omitting weblogic.jar from the classpath, and using a specific <path id=...>
for weblogic.jar and <taskdef>ing it with <classpath refid=...>
- Look at FAQs for optional / third-party tasks for other possible solutions, because I'd
be almost certain your issue is related to the classpath / classloader and Weblogic bringing
in another version of Ant.
 
Hope this helps
Keith
 

	-----Original Message----- 
	From: Hynes Fintan [mailto:Fintan.Hynes@traventec.com] 
	Sent: Thu 04/03/2004 15:10 
	To: 'user@ant.apache.org' 
	Cc: 
	Subject: Ant 1.6 with Weblogic 8.1
	
	


	Hi everyone,
	
	I'm currently attempting to migrate from Ant 1.5.3 to 1.6. 
	As part of my build process I need to invoke the Weblogic Server supplied
	Ant task <wlappc>. 
	Up to this version of Ant, I have just added the weblogic jarfile to the
	classpath and added the taskdef for the weblogic tasks into the
	default.properties file of ant.jar.
	
	This does not seem to work now.  If I add weblogic.jar to the classpath
	(using the -lib option), I get the following error when ant tries to invoke
	the launcher:
	
	java.lang.InstantiationException: org.apache.tools.ant.Main
	        at java.lang.Class.newInstance0(Class.java:291)
	        at java.lang.Class.newInstance(Class.java:259)
	        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:214)
	        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:90)
	
	I've tried removing weblogic.jar from the classpath and putting it in the
	ant lib folder.  This got rid of the above error but it could not see the
	<wlappc> task.  Even if I take the weblogic taskdefs from the
	defaults.properties file and have weblogic.jar in the classpath, I still get
	the launcher exception.
	
	Any help would be much appreciated,
	Fintan
	
	************************************************************************
	This e-mail and any files transmitted with it are confidential and may be
	privileged and are intended solely for the individual named/ for the use of
	the individual or entity to whom they are addressed.If you are not the
	intended addressee, you should not disseminate, distribute or copy this
	e-mail.Please notify the sender immediately if you have received this e-mail
	by mistake and delete this e-mail from your system.If you are not the
	intended recipient, you are notified that reviewing, disclosing, copying,
	distributing or taking any action in reliance on the contents of this e-mail
	is strictly prohibited.Please note that any views or opinions expressed in
	this e-mail are solely those of the author and do not necessarily represent
	those of Traventec Limited.E-mail transmission cannot be guaranteed to be
	secure or error-free as information could be intercepted, corrupted, lost,
	destroyed, or arrive late or incomplete.Traventec Limited therefore does not
	accept liability for any errors or omissions in the contents of this
	message, which arise as a result of e-mail transmission.The recipient should
	check this e-mail and any attachments for the presence of viruses.This
	e-mail has been swept for computer viruses however Traventec Limited accepts
	no liability for any damage caused by any virus transmitted by this e-mail.
	
	---------------------------------------------------------------------
	To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
	For additional commands, e-mail: user-help@ant.apache.org
	
	

Mime
View raw message