ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hugh Field-Richards <h.field-richa...@eris.qinetiq.com>
Subject Re: Ant 1.6.1 Build fail on Mac OX X 10.3.2 (G5)
Date Tue, 02 Mar 2004 08:58:34 GMT
Much better - thanks very much

Hugh F-R

Dr Hugh S. Field-Richards
QinetiQ, St Andrew's Road, Malvern, Worcs, WR14 3PS, UK
Tel: ++1684 895075   Fax: ++1684 896113
Email: h.field-richards@eris.qinetiq.com

The views expressed above area are entirely those of the writer and
do not represent the views, policy or understanding of any other
person or official body.



On 1 Mar 2004, at 16:49, Antoine Lévy-Lambert wrote:

> Try :
> ./bootstrap.sh
> ./build.sh install-lite
>
> you are probably hit by remnants of older versions of ant in the 
> bootstrap dir.
>
> Cheers,
>
> Antoine
>
> Hugh Field-Richards wrote:
>
>> Hi
>>
>> I am upgrading from 1.5.3 and am having a few problems. I get the
>> following failure when I try to build the 1.6.1 source on a Dual G5
>> running OS X 10.3.2.
>>
>> apache-ant-1.6.1 > ./build.sh install-lite
>> ... Bootstrapping Ant Distribution
>> ... Compiling Ant Classes
>> Note: Some input files use or override a deprecated API.
>> Note: Recompile with -deprecation for details.
>> ... Copying Required Files
>> ... Building Ant Distribution
>> Buildfile: build.xml
>>
>> bootstrap:
>>
>> prepare:
>>
>> check_for_optional_packages:
>>
>> build:
>> Created dir: /Library/Packages/apache-ant-1.6.1/build/lib
>>
>> BUILD FAILED
>> file:/Library/Packages/apache-ant-1.6.1/build.xml:602: The <selector> 
>> data type doesn't support the "unless" attribute.
>>
>> Total time: 2 seconds
>> ... Failed Building Ant Distribution !
>> Bootstrap FAILED
>> apache-ant-1.6.1 >
>>
>> This looks as though it s using an old ant version, but the old 1.5.3 
>> ant is no longer
>> in any path. I also tried using the binary distribution but got
>>
>> java.lang.InstantiationException: org.apache.tools.ant.Main
>>         at java.lang.Class.newInstance0(Class.java:293)
>>         at java.lang.Class.newInstance(Class.java:261)
>>         at org.apache.tools.ant.launch.Launcher.run(Launcher.java:196)
>>         at org.apache.tools.ant.launch.Launcher.main(Launcher.java:56)
>>
>> (This also happened on a Linux box). The JAVA_HOME, ANT_HOME, 
>> CLASSPATH
>> and PATH are all seem to be set correctly as far as I can tell - it 
>> certainly was ok for 1.5.3.
>> The problems certainly look like paths not being set up correctly, 
>> but I am at loss
>> to see which.
>>
>> Any help here would be appreciated.
>>
>> TIA
>>
>> Hugh F-R
>>
>>
>>
>>
>> Dr Hugh S. Field-Richards
>> QinetiQ, St Andrew's Road, Malvern, Worcs, WR14 3PS, UK
>> Tel: ++1684 895075   Fax: ++1684 896113
>> Email: h.field-richards@eris.qinetiq.com
>>
>> The views expressed above area are entirely those of the writer and
>> do not represent the views, policy or understanding of any other
>> person or official body.
>>
>>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message