ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique Devienne <DDevie...@lgc.com>
Subject RE: bug in 1.6.1 ?
Date Tue, 30 Mar 2004 20:22:46 GMT
> From: Shandy Brown [mailto:shandy@j2x.ca]
> I want to check that files exist, and only build if they're found.
> 
> It works fine in 1.5.1, but people using 1.6.1 say it craps out with
> 
> 13: unexpected element "available"
> 
> Is <available ...> deprecated?  If not, is this a bug?  Or am I doing
> something wrong.
> 
> Attached is the build.xml file i'm using.  Check the SANITY TEST section.
> 
> shandy

I distilled down your build, and it's working fine for me. --DD

C:\oss\org_apache\antx>set ANT_HOME=C:\pro\ant1.6.1
C:\oss\org_apache\antx>%ANT_HOME%\bin\ant -f available.xml
Buildfile: available.xml
     [echo] all.present = false

BUILD SUCCESSFUL
Total time: 0 seconds
C:\oss\org_apache\antx>type available.xml
<project>
  <available file="${antenna.lib}" property="antenna.lib.present" />
  <available file="${wtk.home}/lib" property="wtk.home.present" />
  <available file="${jpod.home}" property="jpod.home.present" />

  <condition property="all.present">
    <and>
      <isset property="antenna.lib.present" />
      <isset property="wtk.home.present" />
      <isset property="jpod.home.present" />
    </and>
  </condition>
  <property name="all.present" value="false" />

  <echo>all.present = ${all.present}</echo>
</project>
C:\oss\org_apache\antx>%ANT_HOME%\bin\ant -version
Apache Ant version 1.6.1 compiled on February 12 2004
C:\oss\org_apache\antx>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message