ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conelly, Luis (GNF, Contractor)" <Luis.Cone...@gnf.com>
Subject RE: Executing build.xml
Date Wed, 03 Mar 2004 17:55:59 GMT
do you have cvs executable in your path and ant is able to reach it? I've seen this kind of
errors when ant is not able to find the cvs executable file.

>From ant manual[1]

*Important:* This task needs "cvs" on the path. If it isn't, you will get an error (such as
error 2 on windows). If <cvs> doesn't work, try to execute cvs.exe from the command
line in the target directory in which you are working.

Based on that, you must have a cvs client in your local machine and your repository running
somewhere else.

HTH
-Luis

[1] http://ant.apache.org/manual/CoreTasks/cvs.html

-----Original Message-----
From: Zakaria khabot [mailto:z.khabot@ced.mfie.gov.ma]
Sent: Wednesday, March 03, 2004 11:43 AM
To: ANT
Subject: Executing build.xml


 
Hi,
I have CVS  installed in the server machine, ANT is installed in my system, and I have this
error message when I try to execute build.xml in my system.
<cvspass cvsroot=":pserver:username@10.78.0.101:/usr/cvsroot/CVSROOT/Projets/Projet1"

password="*****" passfile=".cvspass" />

and after:

<cvs command="checkout " />

But I got the following error :

[cvs] Caught exception: CreateProcess: cvs commit error=2

Shall I execute the "build.xml" file in the server in order to execute a "checkout".
Can you help me.

Thanks


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message