ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Shields <bgshie...@yahoo.com>
Subject Re: ant ignoring flags
Date Thu, 25 Mar 2004 09:40:24 GMT
i am running windows xp pro. JAVA_HOME is set to j2sdk1.4.2_03 home directory, ANT_HOME is
set to apache-ant-1.6.1 home directory. I have included the ANT_HOME\bin in my PATH variable
also.
 
I have also downloaded ant 1.5.2 and changed the ANT_HOME variable to there. This is the result
from an ant call.....has anything like this happened before? Maybe its my system (which i
should point out ran ant perfectly 2 days ago).
Thanks again,
Brian.
 
C:\tempAnt>ant
Usage: java [-options] class [args...]
           (to execute a class)
   or  java [-options] -jar jarfile [args...]
           (to execute a jar file)
where options include:
    -client       to select the "client" VM
    -server       to select the "server" VM
    -hotspot      is a synonym for the "client" VM  [deprecated]
                  The default VM is client.
    -cp <class search path of directories and zip/jar files>
    -classpath <class search path of directories and zip/jar files>
                  A ; separated list of directories, JAR archives,
                  and ZIP archives to search for class files.
    -D<name>=<value>
                  set a system property
    -verbose[:class|gc|jni]
                  enable verbose output
    -version      print product version and exit
    -showversion  print product version and continue
    -? -help      print this help message
    -X            print help on non-standard options
    -ea[:<packagename>...|:<classname>]
    -enableassertions[:<packagename>...|:<classname>]
                  enable assertions
    -da[:<packagename>...|:<classname>]
    -disableassertions[:<packagename>...|:<classname>]
                  disable assertions
    -esa | -enablesystemassertions
                  enable system assertions
    -dsa | -disablesystemassertions
                  disable system assertions

Matt Benson <gudnabrsam@yahoo.com> wrote:
What are your platform and ant-related environment
variable settings? Always try unsetting the system
CLASSPATH as well.

-Matt


--- Brian Shields wrote:
> Hi all,
> I am new to ant....1 day old in fact. I was running
> ant fine yesterday. 
> Today, however, i was running a simple clean target
> and the compiler 
> crashed due a corrupted jar file in my classpath. I
> have since removed 
> it.
> However now ant is acting strangely...it ignores all
> flags etc typed 
> after ant. For example if i run "ant -version" in a
> folder that does not 
> contain a build.xml file i get a "build process
> failed error" since ant 
> cant find the build file. If there is a build file
> present then it runs 
> the default on this file. I have removed ant and
> downloaded it again 
> but this has not solved the problem.
> Any ideas?
> Brian.
> 
> 
> Do you Yahoo!?
> Yahoo! Finance Tax Center - File online. File on
time.


__________________________________
Do you Yahoo!?
Yahoo! Finance Tax Center - File online. File on time.
http://taxes.yahoo.com/filing.html

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------
Do you Yahoo!?
Yahoo! Finance Tax Center - File online. File on time.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message