ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kyle Adams" <kad...@gfs.com>
Subject Manifest not updating properly?
Date Tue, 03 Feb 2004 21:48:26 GMT
I've got a manifest task that seems to be set properly, but the manifest file is not updating.
 I was wondering if anyone had any insight into how to fix this behavior.

I'm running Ant 1.5.3.  The manifest being modified is:

Ant-Version: Apache Ant 1.5.3
Created-By: 1.3.1_06-b01 (Sun Microsystems Inc.)
Class-Path: lib/struts.jar lib/integrationToolkitCommon_client.jar \
lib/integrationQueueBrowserCommon_client.jar

The manifest task is:

<manifest file="${stage.dir}/META-INF/MANIFEST.MF" mode="update">
  <attribute name="Class-Path" value="lib/tuxPoicComp_client.jar"/>
</manifest>

Debug output (as recorded by the XMLLogger) contains the following tidbit:

<task location="file:/lcl/data/corp/sandbox/component/poic/integration/queuebrowser/snap-poicQueueBrowserApp.xml:416:
" name="manifest" time="0 seconds">
    <message priority="debug"><![CDATA[Manifest has not changed, do not recreate]]></message>
</task>

I'm totally befuddled by the message, "Manifest has not changed, do not recreate", given that
the mode was set to update.  Looking at the source code for the Manifest task, it looks like
the new attribute should've been merged in, the resulting manifest would not be equal (the
Class-Path attribute being different), and the new manifest written to the file.

Thanks,
Kyle

_____

Kyle Adams | Java Developer  |  Gordon Food Service  |  616-717-6162


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message