ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "F. Da Costa" <>
Subject Re: [fileset] Once it worked and now it doesn't?(solved)
Date Thu, 26 Feb 2004 16:12:50 GMT
Matt Benson wrote:

> --- "F. Da Costa" <> wrote:
>>Now it does not want to go through the definition of
>>It just comes back with nothing (even echo only
>>shows the variable instead 
>>of the expected string).
>>Any suggestions? They would be appreciated.
>><pathconvert property="jml.files"
>>refid="jml.files.path" dirsep="/" 
>>pathsep=" "/>
>><echo>files: ${jml.files.path}</echo>
> For your debugging, I would have made the above
>><echo>files: ${jml.files}</echo>
> But that doesn't explain the rest of the problem...
> what do you get if you make the change to the <echo>?
It appears that the fileset definition was incorrect in some way:
changed <include name="${src.dir}/path/to/**/*.java"> to
<include name="**/*.java"> and included the ${src.dir}/path/to in the dir 
attribute of the fileset and now it does run.

So i guess its fine (or should the first snip work as well?)


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message