ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From RADEMAKERS Tanguy <tanguy.rademak...@swift.com>
Subject Re: java.lang.NoSuchMethodError: java/lang/ClassLoader.setPackage AssertionStatus(Ljava/lang/String;Z)V
Date Wed, 18 Feb 2004 14:48:55 GMT
>
>
>Also, I've been dissapointed with the way most tools bundle their Ant
>support.  You may try using a fresh install of ant from outside of WSAD
>(i.e. command line) and see if the problem persists.
>  
>

I haven't used WSAD but i do use Eclipse (which WSAD is based on) and:
- it is possible to change the version of ant used internaly by Eclipse
- Eclipse can use ant as an "external tool" which is sometimes more 
manageable than using the interal ant...

my 0.02$

/t

Paul, R. Chip wrote:

>Whenever I've seen problems like this it's been related (like Dominique
>said) to having either multiple versions of the ant libs or jdk
>installations on the class path.
>
>Also, I've been dissapointed with the way most tools bundle their Ant
>support.  You may try using a fresh install of ant from outside of WSAD
>(i.e. command line) and see if the problem persists.
>
>Chip Paul
>Sr Software Engineer
>ComFrame Software Corporation
> 
>Listen.Understand.Innovate
>www.comframe.com
>
>
>
>-----Original Message-----
>From: priya pallavi [mailto:pry_pallavi@yahoo.com] 
>Sent: Tuesday, February 17, 2004 3:50 PM
>To: Ant Users List
>Subject: RE: java.lang.NoSuchMethodError: java/lang/ClassLoader.setPackage
>AssertionStatus(Ljava/lang/String;Z)V
>
>
>Thanks for your concern Devienne
>
>Dominique Devienne <DDevienne@lgc.com> wrote:> From: priya pallavi
>[mailto:pry_pallavi@yahoo.com]
>  
>
>>Iam using Jdk 1.4.2 , and Ant 1.4.1 that comes with WSAD 5.1.1
>>
>>Dominique Devienne
>>    
>>
>   wrote:> From: priya pallavi
>  
>
>>[mailto:pry_pallavi@yahoo.com]
>>    
>>
>>>When iam trying to compile the files using build.xml using ANT , iam 
>>>getting the followingg exception
>>>
>>>java.lang.NoSuchMethodError: 
>>>java/lang/ClassLoader.setPackageAssertionStatus(Ljava/lang/String;Z)
>>>V
>>>
>>>Any help is much appreciated
>>>      
>>>
>>I'd think this is a JDK 1.4+ only method, so normally Ant uses 
>>reflection to call it. What JDK are you running with? What version of 
>>Ant? --DD
>>    
>>
>
>Ah, OK. Newer version of Ant deal with assertions, so could have been the
>cause of this error, but Ant 1.4.1 does not, so the problem is probably not
>related to Ant, and in any case, you use a JDK which has the missing method,
>so it's a weirder classpath issue, probably.
>
>Sorry, don't know what the problem is. Try running from the command line,
>checking your classpath, this kind of things. Check you don't have two
>version of Ant somehow in your classpath, stuff like that. --DD
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>For additional commands, e-mail: user-help@ant.apache.org
>
>
>
>---------------------------------
>Do you Yahoo!?
>Yahoo! Finance: Get your refund fast by filing online
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>For additional commands, e-mail: user-help@ant.apache.org
>
>
>
>  
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message