ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From RADEMAKERS Tanguy <tanguy.rademak...@swift.com>
Subject Re: is ANT just always says "BUILD SUCCESFUL" ?
Date Fri, 06 Feb 2004 17:22:03 GMT
Shailesh,

That's nothing to do with ant, it's to do with the weblogic deployer i 
have seen this myself: despite the fact that the doc [1] claims that 
wldeploy will fail the build by default if it encounters an error - it 
won't:

here's an example from my hall of shame (failed builds get mailed to us)
...

front.deploy:
 [wldeploy] weblogic.Deployer -remote -verbose -noexit -name eordering -source /scm/vobs/srcSDC/geo/build/front/eordering
-adminurl t3://beswwd70:7001 -user <snip> -password <snip> -redeploy 
 [wldeploy] Initiated Task: [0] [Deployer:149026]Redeploy application eordering on server_7001.
 [wldeploy] Application eordering preparing on server server_7001.
 [wldeploy] Module /eordering: active to prepared on server server_7001.
 [wldeploy] Module /eordering: prepared to unprepared on server server_7001.
 [wldeploy] Module frontEJB: active to prepared on server server_7001.
 [wldeploy] Module frontEJB: prepared to unprepared on server server_7001.
 [wldeploy] Module /CFIDE: active to prepared on server server_7001.
 [wldeploy] Module /CFIDE: prepared to unprepared on server server_7001.
 [wldeploy] Unpexpected Error Initializing Deployer: weblogic.Deployer$DeployerException:
The administration server has dropped the connection. This is most likely because it has shutdown
or you have lost network connectivity.

clean-front.deploy:

BUILD SUCCESSFUL

Total time: 4 minutes 41 seconds


Regs,
/t

[1] http://e-docs.bea.com/xls/docs81/deployment/tools.html


Shailesh Sharma wrote:

>Iam continuing on the help provided to me on this thread.....thanks for all the informations.....i
think i will download and work on this new software called Ant-Contrib may be sometime soon.
But currently iam using ANT and my build.xml file looks something like this:
> 
>    <target name="deploy-now">
>        <echo message="...........This is the developmenet box...deploying......"/>
>        <wldeploy action="${deploy.utility}" upload="true" source="${source}" user="system"
password="weblogic" nostage="true" verbo
>se="true" adminurl="${bedlam-t.admin.url}" debug="true" targets="${cmApplication.target}"/>
>    </target>
> 
>
><target name="deploy-cm-testnet">
> 
><antcall target="deploy-now"> <param name="source" value="${cm1Application.source}"/>
></antcall>
><antcall target="deploy-now"> <param name="source" value="${cm2Application.source}"/>
></antcall>
><antcall target="deploy-now"> <param name="source" value="${cm3Application.source}"/>
></antcall>
> 
>
></target>
> 
> 
>So, basically iam calling my target "deploy-now" three times by using <antcall>.
Now my question is: iam getting BUILD SUCCESFUL although the output looks like:
> 
>
>deploy-now: [echo] ...........This is the developmenet box...deploying...... [wldeploy]
weblogic.Deployer -debug -nostage -verbose -upload -noexit -source /export/home/beamon/applications/clientmanager/CMA_TW_333.war
-targets UPSCAP -adminurl http://bedlam-t.ams1907.com:8001 -user system -password ********
-deploy 
>[wldeploy] DeploymentData : Delete Files:false [wldeploy] Timeout :3600000 [wldeploy]
Targets: [wldeploy] Files: [wldeploy] null 
>[wldeploy] Initiated Task: [87] [Deployer:149026]Deploy application CMA_TW_333 on UPSCAP.
[wldeploy] Application CMA_TW_333 preparing on server upscap_bedlam1t_s1. [wldeploy] Module
CMA_TW_333 failed to transition from unprepared to prepared on server upscap_bedlam1t_s1.
[wldeploy] Application CMA_TW_333 failed on server upscap_bedlam1t_s1. [wldeploy] Task 87
failed: [Deployer:149026]Deploy application CMA_TW_333 on UPSCAP. [wldeploy] Deployment failed
on Cluster UPSCAP [wldeploy] dumping ApplicationException message 
>[wldeploy] Exception:weblogic.management.ApplicationException: prepare failed for CMA_TW_333
[wldeploy] Module: CMA_TW_333 Error: Context path '/CMA/US' is already in use by the module:
CM_NO_333 application: CM_NO_333 
>[wldeploy] dumping ApplicationException message 
>[wldeploy] Exception:weblogic.management.ApplicationException: prepare failed for CMA_TW_333
[wldeploy] Module: CMA_TW_333 Error: Context path '/CMA/US' is already in use by the module:
CM_NO_333 application: CM_NO_333 
>
>[wldeploy] Unpexpected Error Initializing Deployer: weblogic.Deployer$DeployerException:
Deployment exit status=1 
>deploy-now: [echo] ...........This is the developmenet box...deploying...... [wldeploy]
weblogic.Deployer -debug -nostage -verbose -upload -noexit -source /export/home/beamon/applications/clientmanager/CMA_NO_333.war
-targets UPSCAP -adminurl http://bedlam-t.ams1907.com:8001 -user system -password ********
-deploy 
>[wldeploy] DeploymentData : Delete Files:false [wldeploy] Timeout :3600000 [wldeploy]
Targets: [wldeploy] Files: [wldeploy] null 
>[wldeploy] Initiated Task: [88] [Deployer:149026]Deploy application CMA_NO_333 on UPSCAP.
[wldeploy] Application CMA_NO_333 preparing on server upscap_bedlam1t_s1. [wldeploy] Module
CMA_NO_333: active to prepared on server upscap_bedlam1t_s1. [wldeploy] Module CMA_NO_333:
active to prepared on server upscap_bedlam1t_s1. [wldeploy] Module CMA_NO_333: prepared to
unprepared on server upscap_bedlam1t_s1. [wldeploy] Module CMA_NO_333: prepared to unprepared
on server upscap_bedlam1t_s1. [wldeploy] Module CMA_NO_333: unprepared to prepared on server
upscap_bedlam1t_s1. [wldeploy] Module CMA_NO_333: unprepared to prepared on server upscap_bedlam1t_s1.
[wldeploy] Application CMA_NO_333 prepared on server upscap_bedlam1t_s1. [wldeploy] Application
CMA_NO_333 activating on server upscap_bedlam1t_s1. [wldeploy] Module CMA_NO_333: prepared
to active on server upscap_bedlam1t_s1. [wldeploy] Module CMA_NO_333: prepared to active on
server upscap_bedlam1t_s1. [wldeploy] Application CMA_N!
 O!
> _333
> activated on server upscap_bedlam1t_s1. [wldeploy] Task 88 completed: [Deployer:149026]Deploy
application CMA_NO_333 on UPSCAP. [wldeploy] Deployment completed on Cluster UPSCAP 
>
>BUILD SUCCESSFUL 
>
>Please advise ......how can i show that the BUILD is NOT succesful as there were EXCEPTIONS
generated.....is ANT just always says "BUILD SUCCESFUL"
>
>
>Jan.Materne@rzf.fin-nrw.de wrote:
>Yep. 
>
>
>Ant-Contrib:
>Homepage: http://sourceforge.net/projects/ant-contrib/
>CVS-Source:
>http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/ant-contrib/ant-contrib/src/n
>et/sf/antcontrib/
>CVS-Manual:
>http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/ant-contrib/ant-contrib/manua
>l/index.html
>
>http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/*checkout*/ant-contrib/ant-co
>ntrib/manual/tasks/index.html
>
>
>Jan
>
>  
>
>>-----Original Message-----
>>From: Koji Sekiguchi [mailto:koji.sekiguchi@bluemartini.com]
>>Sent: Friday, February 06, 2004 4:59 AM
>>To: Ant Users List
>>Subject: RE: how to run a target multiple times from another target
>>
>>
>>I don't think antcontrib is included with ant. You need to download it
>>separately and put jar file at ${ant.home}/lib.
>>
>>Koji
>>
>>    
>>
>>>-----Original Message-----
>>>From: Shailesh Sharma [mailto:shailesh_scea@yahoo.com]
>>>Sent: Friday, February 06, 2004 1:56 AM
>>>To: Ant Users List
>>>Subject: RE: how to run a target multiple times from another target
>>>
>>>
>>>would AntContrib is included with ANT. Iam using ANT that comes 
>>>with Weblogic server 8.1.
>>>
>>>do i need to install this new software called AntContrib and then 
>>>configure it ......
>>>
>>>-shailesh
>>>
>>>Jan.Materne@rzf.fin-nrw.de wrote:
>>>I would try AntContrib
>>>      
>>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>>For additional commands, e-mail: user-help@ant.apache.org
>>
>>    
>>
>
>
>---------------------------------
>Do you Yahoo!?
>Yahoo! Finance: Get your refund fast by filing online
>  
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message