ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conelly, Luis (PS, GNF, Contractor)" <Luis.Cone...@gnf.com>
Subject RE: java.lang.NoClassDefFoundError: com.sun.mail.util.SharedByteA rray InputStream
Date Wed, 07 Jan 2004 17:51:43 GMT
Cody

	I had a simila issue some time ago with ant 1.5.4; this is what I've got from the list:

---------------------------

You can also install the mail.jar and activation.jar in your $ANT_HOME/lib
directory and remove the encoding="plain" attribute from your build file.
Then ant will use automatically JavaMail, which maybe behaves better for
this problem.

Otherwise :

On this link there is a description of this type of problems.
http://www.fogcreek.com/FogBUGZ/KB/trouble/EmailNotificationProblems.html
and this one
http://www.sendmail.org/faq/section3.html#3.27

---------------------------

HTH
-Luis

-----Original Message-----
From: Fyler, Cody A [mailto:CodyFyler@financial.wellsfargo.com]
Sent: Wednesday, January 07, 2004 11:48 AM
To: 'Ant Users List'
Subject: RE: java.lang.NoClassDefFoundError:
com.sun.mail.util.SharedByteA rray InputStream


Sorry, forgot to switch to plain text.

-----Original Message-----
From: Fyler, Cody A [mailto:CodyFyler@financial.wellsfargo.com]
Sent: Wednesday, January 07, 2004 11:46 AM
To: 'user@ant.apache.org'
Subject: java.lang.NoClassDefFoundError: com.sun.mail.util.SharedByteArray
InputStream


Hi,
    I'm using Ant 1.6 and cannot get the mail task to work at all. I keep
getting the error in the subject. I've made sure that the JavaMail jars are
in my classpath. What am I doing wrong?

Cody Fyler
Web Developer
Wells Fargo Financial
(515) 557-7828
codyfyler@financial.wellsfargo.com
MAC# F4030-032

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message