ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tsai Fu-Ming <sary...@pchome.com.tw>
Subject Some question about installation...
Date Fri, 30 Jan 2004 06:55:56 GMT
Hello:
I have some problem when I installed ANT.
The version of ANT that I installed is 1.6.0, The version of JAVA is
1.4.2_03, and I use redhat 9.0.
After I installed the binary edition of ANT, I tried to type "ANT -version".
The system has following message:

[root@localhost script]# ant -version
java.lang.IllegalArgumentException
at sun.net.www.ParseUtil.decode(ParseUtil.java:155)
at sun.misc.FileURLMapper.getPath(FileURLMapper.java:47)
at sun.misc.FileURLMapper.exists(FileURLMapper.java:56)
at sun.misc.URLClassPath$JarLoader.getJarFile(URLClassPath.java:572)
at sun.misc.URLClassPath$JarLoader.<init>(URLClassPath.java:542)
at sun.misc.URLClassPath$3.run(URLClassPath.java:320)
at java.security.AccessController.doPrivileged(Native Method)
at sun.misc.URLClassPath.getLoader(URLClassPath.java:309)
at sun.misc.URLClassPath.getLoader(URLClassPath.java:286)
at sun.misc.URLClassPath.getResource(URLClassPath.java:156)
at java.net.URLClassLoader$1.run(URLClassLoader.java:191)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:213)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:90)

Obviously, the ANT can not run............

I tried to find a solution about this case.However, when I use the ant
file of the version 1.5.4 of ANT,
the system has the following message:

[root@localhost script]# ant -version
Apache Ant version 1.6.0 compiled on December 18 2003

My problem is why the ANT can not run when I use the ant file of the
version 1.6.0, but the ANT can run
when I use the ant file of the version 1.5.4. Please reply me if anyone
knows. Thanks.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message