ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Baz" <ba...@goodconsultants.com>
Subject Please help with Ant/Junit
Date Sat, 17 Jan 2004 09:44:25 GMT
All,

I am a newbie and would like to use junit in my build.xml. However, it keep
giving me the following errors... Please help!!! I know it might be doing
with my CLASSPATH, but how can i define it? Please help asap. Its urgent
:( I think I just do not know how to set the environment correctly.

Please email me directly. Thanks in advance.

B.

test:
    [junit] Running XyzTest
    [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec
    [junit] Testsuite: XyzTest
    [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec

    [junit] Null Test:  Caused an ERROR
    [junit] XyzTest
    [junit] java.lang.ClassNotFoundException: XyzTest
    [junit]     at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
    [junit]     at java.security.AccessController.doPrivileged(Native
Method)
    [junit]     at
java.net.URLClassLoader.findClass(URLClassLoader.java:187)
    [junit]     at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
    [junit]     at
sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)

    [junit]     at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
    [junit]     at java.lang.ClassLoader.loadClass(ClassLoader.java:235)


    [junit] TEST XyzTest FAILED

BUILD SUCCESSFUL



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message