ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "*" <kes...@absamail.co.za>
Subject Re: Installing Ant on WinMe
Date Thu, 22 Jan 2004 15:58:21 GMT
Hi Simon,
Thanks very much for your reply.
Your memory is good, I found the setting just like you said, right-click the
dos-prompt.
I've done what you suggested, and set the initial environment to the max of
4096 bytes, but unfortunately I still have the same problem.
Strange that the 'MS-Dos Prompt Properties'  help message says that, "with
the setting on 'auto' the initial size of the environment is determined by
the SHELL= line in the config.sys file.".
The M$ article, referred to below, says there is no config.sys file?? A case
of the left hand not knowing what the right hand do'ith!
I will consult the archives as you suggest.
Kind regards,
Tom


----- Original Message -----
From: "Chappell, Simon P" <Simon.Chappell@landsend.com>
To: "Ant Users List" <user@ant.apache.org>
Sent: Thursday, January 22, 2004 4:41 PM
Subject: RE: Installing Ant on WinMe


It's been a while since I installed ant on a WinME box, and I since started
using for other operating systems, so I'm flying by memory here:

1. To update the environment size, I think that you right click on the
command line icon, select properties and somewhere in there is an option to
increase environment size. (It may not be the command line icon, try the My
Computer if that doesn't work .... you right click on something and set the
environment size! :-)

2. The other big thing with ant under WinME was that the install path was
best kept short and with no spaces in it. This ruled out "Program Files" of
course and so I ended up installing it in something like "C:\ant". Worse
things happen at see, but it did mean that I could successfully run ant on
WinME.

I think that I got most of my information from searching the ant mailing
list archives, so you may want to try that as well (you'll see my efforts to
solve the same problem in there!)

I hope that these fuzzy recollections help in some way, shape or form. :-)

Simon

>-----Original Message-----
>From: * [mailto:keseng@absamail.co.za]
>Sent: Thursday, January 22, 2004 8:19 AM
>To: Ant Users List
>Subject: Installing Ant on WinMe
>
>
>Hi all,
>I am having difficulty in installing Ant 1.6 on a WinMe
>machine. The Ant
>manual assumes that Win9x, NT behave the same as WinMe, which
>is not the
>case. Some help is much needed here!
>I get an "Out Of Environment Space" error a few times and then
>a "Bad file
>name" error, when calling ant.bat.
>The Ant manual suggests adding 'shell=c:\command.com c:\ /p
>/e:32768' to the
>config.sys file, but on WinMe there is no config.sys file -
>see M$ knowledge
>base article at http://support.microsoft.com/?kbid=274646.
>Any Dos environment changes which are required should
>apparently be made in
>a cmdinit.bat file, which is run each time the Dos window is
>called from
>WinMe.
>Adding the shell=entry line to this batch file, however,  has
>not made any
>difference to my install problem.
>I will be grateful to find someone out there who can help?
>
>I have tried with Ant1.5 with the same result, so I don't
>think it's the
>version of Ant.
>
>Regards,
>Tom.
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>For additional commands, e-mail: user-help@ant.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message