ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ravi Nistala NONLILLY <NISTALA_RAVI_NONLI...@LILLY.COM>
Subject sending e-mail through Ant V 1.5
Date Wed, 24 Dec 2003 15:21:40 GMT
====================================================
Ravi Nistala
(317) 277- 7066
Discovery OLO - Reference DB Project
nistalarn@lilly.com
----- Forwarded by Ravi Nistala NONLILLY/AM/LLY on 12/24/2003 10:21 AM 
-----


Ravi Nistala NONLILLY
12/24/2003 10:11 AM

 
        To:     user-subscribe@ant.apache.org
        cc:     erik@hatcher.net
        Subject:        sending e-mail through Ant V 1.5


we are using Ant v 1.5 in websphere studio V5.1 to send e-mail after the 
successful completion of the build.
we are getting a weired error as follows.
BUILD FAILED: java.lang.NoClassDefFoundError: 
com.sun.mail.util.SharedByteArrayInputStream
we added the mail.jar from java to the classpath.
also added activation.jar from java site.
acvtuallly it teh above said clas file is there.still it is not able to 
find that one out.
our task definition is as follows:
<target name="NotifyWithLogFile" if="LogFileName">

 
                <mail from    ="${FromEmail}"
                          tolist  ="${ToEmail}"
                      mailhost="${MailHost}" 
                      subject ="${Subject}"
                          message ="${Message}"
                          files   ="${TemporaryLogFileName}"
                          >
                </mail>


        </target>

Can you help me with this problem.
====================================================
Ravi Nistala
(317) 277- 7066
Discovery OLO - Reference DB Project
nistalarn@lilly.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message