ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan.Mate...@rzf.fin-nrw.de
Subject RE: copy task not copying
Date Thu, 18 Dec 2003 08:06:27 GMT
build_properties:
Skipped because property 'name' not set.
...


Is the <copy> statement inside a 
  <target name="build_properties" if="name">
? Then that is only executed if the 'name' property is set.


Jan



> -----Original Message-----
> From: Mark R. Diggory [mailto:mdiggory@latte.harvard.edu]
> Sent: Thursday, December 18, 2003 5:18 AM
> To: user@ant.apache.org
> Subject: copy task not copying
> 
> 
> I've been trying to determine why my build script that uses 
> the <copy> 
> task isn't copying and I'm very stumped. I've explored all 
> the obvious 
> (user permissions, parameters and locations of 
> files/directories). I've 
> increased verbosity in executing the script. Oddly there are not even 
> any logging messages suggesting the copy task was even run.
> 
> Any help or information anyone could provide would be highly 
> appreciated.
> 
> snip from build.xml
> 
> <copy todir="${deploy.home}">
>     <fileset dir="${src.home}">
>        <exclude name="**/Custom/**"/>
>        <exclude name="**/Statistics/**"/>
>        <include name="**/Statistics/index.jsp"/>
>        <exclude name="**/*.class"/>
>     </fileset>
> </copy>
> 
> 
> <!--snip from verbose log-->
> bash-2.05a# ant -v
> Apache Ant version 1.5.4 compiled on August 13 2003
> Buildfile: build.xml
> Detected Java version: 1.3 in: 
> /usr/lib/jvm/java-1.3.1-sun-1.3.1.09/jre
> Detected OS: Linux
> parsing buildfile build.xml with URI = 
> file:/home/mdiggory/VDC/src/UIS/VDC/WEB-INF/build.xml
> Project base dir set to: /home/mdiggory/VDC/src/UIS/VDC/WEB-INF
> Build sequence for target `compile' is [init, backup-app, prepare, 
> build_properties, build_support, compile]
> Complete build sequence is [init, backup-app, prepare, 
> build_properties, 
> build_support, compile, generate-ddi, compile-jsp, deploy, 
> clean, rmlf]
> 
> <!--snip from where the copy task should be generating logging-->
> prepare:
>     [delete] Deleting 206 files from /usr/local/VDC/UIS/VDC
> <!--...-->
>     [delete] Deleting 
> /usr/local/VDC/UIS/VDC/WEB-INF/classes/edu/harvard/hmdc/util/U
> til.class
>     [delete] Deleting 
> /usr/local/VDC/UIS/VDC/WEB-INF/classes/edu/harvard/hmdc/VDCSta
> tusException.class
> 
> <!-- copy task should at least log here! But nothing comes out.-->
> 
> 
> build_properties:
> Skipped because property 'name' not set.
> ...
> 
> 
> thanks,
> Mark
> 
> -- 
> Mark Diggory
> Software Developer
> Harvard MIT Data Center
> http://osprey.hmdc.harvard.edu
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message