ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Lévy-Lambert <anto...@antbuild.com>
Subject Re: Ant 1.6 beta3 fails on windows xp pro
Date Mon, 15 Dec 2003 18:15:34 GMT
Siri Nivasam wrote:

> I am running ant 1.6 beta 3 on windows xp pro with sp1.
>
> I get this error when I run 'ant -version'
>
> java.lang.InstantiationException: org.apache.tools.ant.Main
>        at java.lang.Class.newInstance0(Class.java:293)
>        at java.lang.Class.newInstance(Class.java:261)
>        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:214)
>        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:90)
>
> Can anybody tell why?
>
> Siri
>
>
>
Hi Siri,

I cannot tell why, but it does not sound good.

Can you tell :

- where is ant 1.6 beta3 installed on your computer,
- which JDK you are using,
- what are the settings of JAVA_HOME and ANT_HOME in your environment,
- is the variable CLASSPATH defined in your environment ?

My recommendations :

- unset CLASSPATH completely to try to debug the problem,
- set ANT_HOME to the installation directory of ant ( not necessary, but 
does not harm)
- set JAVA_HOME to whereever your JDK is installed
make sure that the ant version 1.6beta3 bin is in your path, ahead of 
other ant versions,
make sure that the JDK's bin directory that you want to use is also 
ahead in the PATH

Cheers,

Antoine

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message