ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jack Woehr <...@purematrix.com>
Subject Re: Problem on OS/400
Date Mon, 08 Dec 2003 17:20:47 GMT
Chris Wood wrote:

> I then get the two lines:
>    ... Bootstrapping Ant Distribution
>    ... Compiling Ant Classes
>
> Just like I get on other platforms, such as Linux.
>
> However, after a suitably OS400-sized pause, I then get a large stream
> of errors.
> The first one is:
>  src/main/org/apache/tools/ant/Project.java:65: Class java.util.Iterator
> not found in import.    import java.util.Iterator;           ^

Ah, now we are making progress. It does appear, don't you think, that either
your installation is incomplete or the classpath is not properly set. Since you
say your installation works otherwise, one guesses that one of the ANT scripts
is setting the classpath incorrectly.

> should have this class. Note that the IBM supplied J2sdk is a little odd
> - it doesn't have a jre directory - the rt.jar file is in the main lib
> directory. Manually setting the classpath to this makes zero difference.

When you say "manually set" do you mean "by modifying the ANT build script(s)"
or "setting prior to the scripts' execution"? It should be the former ... see how the ANT
scripts work and modify them accordingly.

If I have time I will log into a friend's OS/400 box and try myself to build ANT. I'm a bit
busy but will try to make the time, I'm getting interested.

--
Jack J. Woehr            # "[F]ar in the empty sky a solitary esophagus slept
http://www.well.com/~jax #  upon motionless wing; everywhere brooded stillness,
http://www.softwoehr.com #  serenity, and the peace of God." - Mark Twain




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message