ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastien Blanc <Sebastien.Bl...@alcatel.com>
Subject Re: Can't start ANT 1.5 on WinNT
Date Mon, 01 Dec 2003 16:15:10 GMT
I'm using '/' for my win32 env.bat:

SET JAVA_HOME=%VOBROOT%/cc/tnd_cots_java/staging
SET JAVA_BIN=%JAVA_HOME%/bin
SET JAVA_LIB=%JAVA_HOME%/lib
SET JAVA_BOOTPATH=%JAVA_HOME%/jre

and it works fine. could try it,
seb.

Eric.dl.De_Loof@alcatel.fr wrote:

> Adding quotes on the PATH environment is unsuccessfull  :(
>
> set JAVA_HOME="C:\Program Files\j2sdk1.4.1_05"
> set ANT_HOME="C:\Program Files\jwsdp-1.3\apache-ant"
> set JWSDP_HOME="C:\Program Files\jwsdp-1.3"
> etc..
>
>   ----- Original Message -----
>   From: Priyapravas
>   To: Ant Users List
>   Sent: Monday, December 01, 2003 3:47 PM
>   Subject: Re: Can't start ANT 1.5 on WinNT
>
>   This could be far-fetched, but considering you are on a Win32 box, can you include
all the environment variables within quotes? I think the JVM is confused with your environment
variable settings. I have had this problem earlier on Win32 (WINNT to be specific) and I simply
included my variables within quotes and it worked.
>
>   Cheers,
>   -Priyapravas
>
>   On Dec 1, 2003, at 8:08 PM, Eric.dl.De_Loof@alcatel.fr wrote:
>
>     setenv.bat :
>     set JAVA_HOME=C:\Program Files\j2sdk1.4.1_05
>     set ANT_HOME=C:\Program Files\jwsdp-1.3\apache-ant
>     set JWSDP_HOME=C:\Program Files\jwsdp-1.3
>
>     Control panel / System :
>     C:\Program Files\j2sdk1.4.1_05\bin;C:\Program Files\jwsdp-1.3\bin;C:\Program
>     Files\jwsdp-1.3\jwsdp-shared\bin;C:\Program Files\jwsdp-1.3\apache-ant\bin;
>
>     Command to be executed from a MS-DOS Console (cmd.exe) :
>     - ant
>     - or ant -version
>     Result is the same whatever the directory is !
>
>       Exception in thread "main" in Java.lang.NoClassDefFoundError
>       : Files J2sdk1/4/1_05\lib\tools/jar;c:\Program
>
>     Is it normal that we get J2sdk1/4/1_05\lib\tools/jar instead of
>     J2sdk1.4.1_05\lib\tools.jar ?
>
>     Thanks for your help !
>     Eric
>
>     ----- Original Message -----
>     From: <Jan.Materne@rzf.fin-nrw.de>
>     To: <user@ant.apache.org>
>     Sent: Monday, December 01, 2003 3:08 PM
>     Subject: RE: Can't start ANT 1.5 on WinNT
>
>     Sorry, I didnĀ“t understand.
>
>     - in which directory you are
>     - what is the command you type in
>     - what is the value of
>     ANT_HOME
>     JAVA_HOME
>     PATH
>     - does "ant -version" work?
>
>     Jan
>
>       -----Original Message-----
>       From: Eric.dl.De_Loof@alcatel.fr [mailto:Eric.dl.De_Loof@alcatel.fr]
>       Sent: Monday, December 01, 2003 2:50 PM
>       To: user@ant.apache.org
>       Subject: Can't start ANT 1.5 on WinNT
>
>       Hello all !
>
>       I installed SUN Web Services Developper Pack 1.3 which
>       includes apache-ant 1.5.
>       OS : Win NT or XP Pro
>
>       When i launch ant (c:\ant), i get following message :
>
>       Exception in thread "main" in Java.lang.NoClassDefFoundError
>       : Files J2sdk1/4/1_05\lib\tools/jar;c:\Program
>
>       Any suggestion ?
>
>       NB : ClassPath is empty
>       LocalClassPath does not exist
>
>       Eric
>
>     ---------------------------------------------------------------------
>     To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>     For additional commands, e-mail: user-help@ant.apache.org
>
> ------------------------------------------------------------------------------
>
>   ---------------------------------------------------------------------
>   To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>   For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message