ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Conor MacNeill <co...@cortexebusiness.com.au>
Subject Re: Very odd issue with jar task
Date Sun, 07 Dec 2003 23:45:03 GMT
On Sat, 6 Dec 2003 06:51 am, Armbrust, Daniel C. wrote:
> I have a very frustrating problem that I hope someone may be able to shed a
> bit of light on....  Sorry for the lengthy post, but I wanted to get all
> the details out here.
>
>
> This has worked fine up until yesterday.  Now, when I run compile, I get
> this exception: Buildfile: D:\Eclipse
> Projects\general-workspace\ctsbackend\build.xml init:
>     [mkdir] Created dir: D:\Eclipse
> Projects\general-workspace\ctsbackend\antBuild compile:
>     [mkdir] Created dir: D:\Eclipse
> Projects\general-workspace\ctsbackend\antBuild\classes [javac] Compiling 8
> source files to D:\Eclipse
> Projects\general-workspace\ctsbackend\antBuild\classes [javac] An exception
> has occurred in the compiler (1.4.2_02). Please file a bug at the Java
> Developer Connection (http://java.sun.com/cgi-bin/bugreport.cgi)  after
> checking the Bug Parade for duplicates. Include your program and the
> following diagnostic in your report.  Thank you. [javac]
> java.lang.IndexOutOfBoundsException

There used to be a problem when modifying jars which had been previously 
loaded by the VM. I am not 100% sure if this is the same. It went something 
like this - you refer to the existing jar prior to building it (in a 
classpath, for example), build or update the jar and then use it in a 
compile.

Here are some bug reports about the issue
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=383
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=6715
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=1035


Now those iussues are menat to be resolved in the 1.3.1 VM so maybe not the 
same issue. Some things to check: 
1. Are you using the jar in a classpath in the same build?
2. Does deleting the jar before running the build change things?
3. Does forking the compile change things?

Conor


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message