ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Wood <ch...@thesprocket.org>
Subject Re: Problem on OS/400
Date Tue, 09 Dec 2003 10:23:42 GMT
On Mon, 2003-12-08 at 17:27, Peter Reilly wrote:
> java.util.Iterator is part of the std java classes since 1.2. You should 
> not be able
> to get this message unless you are using a 1.1 jvm.
> 
> Ant 1.6 needs a 1.2 jvm, ant 1.5 and before is happy with a 1.1 jvm.
> Peter
> 

Yup, I understand this. The machine has 1.1, 1.2 and 1.3 on it, from the
packages supplied by IBM.
I had explicitly set the JAVA_HOME variable to the 1.3 version before
running the script.
I know little about the intricacies of OS/400 (I'm a unix man mainly),
but from a look at the files that comprise the jdk, there is no jre
subdirectory, so things do look rather different to what I'm expecting
to see.

I've not got much experience with IBM JDKs. Could this be a common
feature of them, or perhaps it's just OS/400 specific? I have access to
an AIX unix machine, so will do a bit of digging to see what things are
like there.

Regards,

Chris



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message