ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Wood <ch...@thesprocket.org>
Subject Re: Problem on OS/400
Date Tue, 09 Dec 2003 10:18:09 GMT
On Mon, 2003-12-08 at 18:54, Jack Woehr wrote:
> Chris Wood wrote:
> 
> > However, after a suitably OS400-sized pause, I then get a large stream
> > of errors.
> > The first one is:
> >  src/main/org/apache/tools/ant/Project.java:65: Class java.util.Iterator
> > not found in import.    import java.util.Iterator;           ^
> >
> 
> Hmm, I seem to get a lot of errors about "illegal characters". Wonder if there's some
sort
> of ASCII/EBCDIC thing here. If I find more time I'll look at this some more.
> 

I got something similar when I extracted natively on OS/400 from a tar
package. However, I got round this issue by extracting on a linux box,
then repackaging using zip (jar would work too). This was then natively
extracted using jar on the OS/400. The odd thing about this is that if
you look at the files extracted with tar by using, say the the wrklnk
tool, then they look just fine - it's not until you actually try to
compile things that you get the error you mention above.

Had forgotten all about this problem until you mentioned it. Try as per
above to work around it.

Thanks for you time,

C.



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message