ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: Can't start ANT 1.5 on WinNT
Date Tue, 02 Dec 2003 18:44:17 GMT
Of course "C:\Progra~1\jwsdp-1.3\apache-ant" won't work.  That's because it is 
supposed to be:
C:\Progra~1\jwsdp-1.3\apache-ant

Don't add quotes.  That's the whole point of Progra~1, so you can avoid quotes, 
yet still have a path with no spaces in it.

Jake

Quoting Eric.dl.De_Loof@alcatel.fr:

> 
> binaries (ant...)  are no more accessible when environment is set with
> "C:\Progra~1\jwsdp-1.3\apache-ant" (ant : file note found)
> 
> "C:\Program Files\jwsdp-1.3\apache-ant" works better...
> 
> ----- Original Message -----
> From: "Jacob Kjome" <hoju@visi.com>
> To: "Ant Users List" <user@ant.apache.org>
> Sent: Tuesday, December 02, 2003 4:31 AM
> Subject: Re: Can't start ANT 1.5 on WinNT
> 
> 
> 
> JAVA_HOME=C:\Progra~1\j2sdk1.4.1_05
> ANT_HOME=C:\Progra~1\jwsdp-1.3\apache-ant
> JWSDP_HOME="C:\Progra~1\jwsdp-1.3
> 
> Beyond that, I recommend that you install the packages to paths without
> spaces.  Stay away from "Program Files".
> 
> Also, make sure that nothing on your classpath has spaces.
> 
> Jake
> 
> At 05:06 PM 12/1/2003 +0100, you wrote:
> >Adding quotes on the PATH environment is unsuccessfull  :(
> >
> >set JAVA_HOME="C:\Program Files\j2sdk1.4.1_05"
> >set ANT_HOME="C:\Program Files\jwsdp-1.3\apache-ant"
> >set JWSDP_HOME="C:\Program Files\jwsdp-1.3"
> >etc..
> >
> >
> >
> >   ----- Original Message -----
> >   From: Priyapravas
> >   To: Ant Users List
> >   Sent: Monday, December 01, 2003 3:47 PM
> >   Subject: Re: Can't start ANT 1.5 on WinNT
> >
> >
> >   This could be far-fetched, but considering you are on a Win32 box, can
> > you include all the environment variables within quotes? I think the JVM
> > is confused with your environment variable settings. I have had this
> > problem earlier on Win32 (WINNT to be specific) and I simply included my
> > variables within quotes and it worked.
> >
> >   Cheers,
> >   -Priyapravas
> >
> >   On Dec 1, 2003, at 8:08 PM, Eric.dl.De_Loof@alcatel.fr wrote:
> >
> >
> >
> >     setenv.bat :
> >     set JAVA_HOME=C:\Program Files\j2sdk1.4.1_05
> >     set ANT_HOME=C:\Program Files\jwsdp-1.3\apache-ant
> >     set JWSDP_HOME=C:\Program Files\jwsdp-1.3
> >
> >     Control panel / System :
> >     C:\Program Files\j2sdk1.4.1_05\bin;C:\Program
> > Files\jwsdp-1.3\bin;C:\Program
> >     Files\jwsdp-1.3\jwsdp-shared\bin;C:\Program
> > Files\jwsdp-1.3\apache-ant\bin;
> >
> >
> >     Command to be executed from a MS-DOS Console (cmd.exe) :
> >     - ant
> >     - or ant -version
> >     Result is the same whatever the directory is !
> >
> >       Exception in thread "main" in Java.lang.NoClassDefFoundError
> >       : Files J2sdk1/4/1_05\lib\tools/jar;c:\Program
> >
> >     Is it normal that we get J2sdk1/4/1_05\lib\tools/jar instead of
> >     J2sdk1.4.1_05\lib\tools.jar ?
> >
> >
> >     Thanks for your help !
> >     Eric
> >
> >
> >     ----- Original Message -----
> >     From: <Jan.Materne@rzf.fin-nrw.de>
> >     To: <user@ant.apache.org>
> >     Sent: Monday, December 01, 2003 3:08 PM
> >     Subject: RE: Can't start ANT 1.5 on WinNT
> >
> >
> >     Sorry, I didnĀ“t understand.
> >
> >     - in which directory you are
> >     - what is the command you type in
> >     - what is the value of
> >     ANT_HOME
> >     JAVA_HOME
> >     PATH
> >     - does "ant -version" work?
> >
> >
> >     Jan
> >
> >
> >
> >       -----Original Message-----
> >       From: Eric.dl.De_Loof@alcatel.fr [mailto:Eric.dl.De_Loof@alcatel.fr]
> >       Sent: Monday, December 01, 2003 2:50 PM
> >       To: user@ant.apache.org
> >       Subject: Can't start ANT 1.5 on WinNT
> >
> >
> >       Hello all !
> >
> >       I installed SUN Web Services Developper Pack 1.3 which
> >       includes apache-ant 1.5.
> >       OS : Win NT or XP Pro
> >
> >       When i launch ant (c:\ant), i get following message :
> >
> >       Exception in thread "main" in Java.lang.NoClassDefFoundError
> >       : Files J2sdk1/4/1_05\lib\tools/jar;c:\Program
> >
> >       Any suggestion ?
> >
> >       NB : ClassPath is empty
> >       LocalClassPath does not exist
> >
> >
> >       Eric
> >
> >
> >
> >
> >
> >
> >     ---------------------------------------------------------------------
> >     To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> >     For additional commands, e-mail: user-help@ant.apache.org
> >
> >
> >
> >
> >---------------------------------------------------------------------------
> ---
> >
> >
> >   ---------------------------------------------------------------------
> >   To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> >   For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message