ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "didge" <di...@foundrylogic.com>
Subject RE: Build pauses on Linux
Date Mon, 24 Nov 2003 21:50:08 GMT
Did you run hdparm?
http://linux.oreillynet.com/pub/a/linux/2000/06/29/hdparm.html.

didge

> -----Original Message-----
> From: Clifton Craig [mailto:ccc@icsaward.com]
> Sent: Monday, November 24, 2003 1:11 PM
> To: Ant Users List
> Subject: Build pauses on Linux
>
>
> Hell all,
>
> I just don't know where else to turn on this problem. I have a rather
> involved and lengthy build process that has been running without
> fail until
> recently. I've been developing the build on WinXP and running it on both
> WinXP and Redhat 9 without fail. We have now setup a new
> development machine
> which I believe is Redhat 9 as well and I every time I run the build it
> pauses. I'm new to Linux so I'm not sure what state the process is in when
> it pauses. When I say it pauses I mean it does just that. It stops running
> and stops logging. I've tried many renditions of executing the build
> including running it in the background, running it in the foreground,
> with/without logging, logging to both the screen and disk, any and all
> combinations of the above. Normally what happens in all cases is
> it gets 1/2
> way through and just stops in the middle of the EJB task for
> JOnAS. You see
> we have about 50 or so EJBs that are compiled/jarred for JOnAS
> v3.3 in this
> build using their current ejbjar task. It appears to stop at random points
> all the time. For example, if the beans were numbered 1-50
> sometimes it will
> stop at bean 32, sometimes it will stop at bean 43, etc. It doesn't
> continually stop at the same bean. What's more if I re-run it
> after it stops
> it won't finish all the way. It only builds a few more beans and hangs up
> again. I have to run the build 3-4 times to get all the way through. I've
> tried using the "top" command when it pauses to see where the
> process is and
> it looks like its in a "SLEEP" status according to the man pages for top.
> Forgive me, as I don't know enough about Linux to understand why this is
> happening or even if the process is still alive. The same build runs on
> another (beefier) Linux box without fail. Has anyone ever run into such a
> problem before? Can anyone help me?
>
> Clifton C. Craig
> Intelligent Computer Systems
> A division of Global Beverage Group
> ccc@icsaward.com
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message