ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject <script> dependencies?
Date Sat, 29 Nov 2003 03:31:50 GMT

I have been trying to get <script> to work with javascript and/or beanshell 
in Ant 1.6 (recent nightly build).  I read about the dependencies.  I have 
BSF 2.3.0RC1, Rhino 1.5R3, and BSH1.3.0 (also tried BSH 2.0b1) in 
ANT_HOME/lib.  All I ever get, though, is what you see below.  Any hints?

Running this...

     <target name="javascript">
         <script language="javascript"> <![CDATA[
         java.lang.System.out.println("Hello World");
         ]]></script>
     </target>

I get...


BUILD FAILED
D:\myclasses\Repository\Jakarta\build.xml:21: Following error occured while 
exec
uting this line
D:\myclasses\Repository\Jakarta\build.xml:8: Could not create task or type 
of ty
pe: script.

Ant could not find the task or a class this task relies upon.

This is common and has a number of causes; the usual
solutions are to read the manual pages then download and
install needed JAR files, or fix the build file:
  - You have misspelt 'script'.
    Fix: check your spelling.
  - The task needs an external JAR file to execute
    and this is not found at the right place in the classpath.
    Fix: check the documentation for dependencies.
    Fix: declare the task.
  - The task is an Ant optional task and optional.jar is absent
    Fix: look for optional.jar in ANT_HOME/lib, download if needed
  - The task was not built into optional.jar as dependent
    libraries were not found at build time.
    Fix: look in the JAR to verify, then rebuild with the needed
    libraries, or download a release version from apache.org
  - The build file was written for a later version of Ant
    Fix: upgrade to at least the latest release version of Ant
  - The task is not an Ant core or optional task
    and needs to be declared using <taskdef>.

Remember that for JAR files to be visible to Ant tasks implemented
in ANT_HOME/lib, the files must be in the same directory or on the
classpath

Please neither file bug reports on this problem, nor email the
Ant mailing lists, until all of these causes have been explored,
as this is not an Ant bug.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message