ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Wood <ch...@thesprocket.org>
Subject [input] task broken in NetWare?
Date Tue, 25 Nov 2003 15:01:30 GMT
Hi all,

I've been having some troubles getting Ant 1.6beta2 to work correctly on
NetWare 6.

Here's what I do:

setenv ANT_HOME=<path to ant>
perl $ANT_HOME\bin\runant.pl -debug -f <path to build file>

Here's the output of relevance:
configure.install.dir:
    [input] Directory to install to:
43)
        at org.apache.tools.ant.Project.demuxInput(Project.java:1161)
        at
org.apache.tools.ant.DemuxInputStream.read(DemuxInputStream.java:89)
        at java.io.FilterInputStream.read(FilterInputStream.java:69)
        at java.io.DataInputStream.readLine(DataInputStream.java,
Compiled Code)

        at
org.apache.tools.ant.input.DefaultInputHandler.handleInput(DefaultInp
utHandler.java, Compiled Code)
        at org.apache.tools.ant.taskdefs.Input.execute(Input.java:156)
        at
org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:302)
        at org.apache.tools.ant.Task.perform(Task.java:401)
        at org.apache.tools.ant.Target.execute(Target.java, Compiled
Code)
        at org.apache.tools.ant.Target.performTasks(Target.java:365)
        at org.apache.tools.ant.Project.executeTarget(Project.java,
Compiled Cod
e)
        at org.apache.tools.ant.Project.executeTargets(Project.java,
Compiled Co
de)
        at org.apache.tools.ant.Main.runBuild(Main.java, Compiled Code)
        at org.apache.tools.ant.Main.startAnt(Main.java, Compiled Code)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java,
Compiled Code
)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:90)

Total time: 3 seconds
java: Class org.apache.tools.ant.launch.Launcher exited with status 1


As you can see, java dumps when I try and get input from the user.
I had the same sort of problem in ant 1.5.3-1, but thought I'd try again
with 1.6beta2 to see if it had been fixed. Looks like it hasn't.
Everything else seems to work just fine.

Has anyone seen this before or know how to sucessfully read input on
NetWare?

Cheers,

C.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message