ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "W. Sean Hennessy" <shenne...@goldenhourdata.com>
Subject RE: RMIC under windows and linux
Date Fri, 14 Nov 2003 19:55:29 GMT
<rmic base="build" classname="Server${file.separator}RMIServer" debug="on"/>

-----Original Message-----
From: Gerrit Hulleman [mailto:hulleman@lupus-delta.tmfweb.nl] 
Sent: Friday, November 14, 2003 11:14 AM
To: user@ant.apache.org
Subject: RMIC under windows and linux


A little problem trying to build my app. Situation is:
 Package Server class RMIServer
This class needs to be used with rmic, so in ant build.xml the following line is present:
    <rmic base="build" classname="Server/RMIServer" debug="on"/>

Under linux, this works find. Under windows an error occured:
    [rmic] error: Class Server/RMIServer not found.

After some experimenting I found out that when the slash is flipped to 
    <rmic base="build" classname="Server\RMIServer" debug="on"/> Windows builds fine.
But now linux produces the same
error as before under windows.

Is there a way to detect the environment OS so that the under linux one line is used, and
under windows the other. Or
perhaps there is a better solution?

Many tnxs for some info...

Gerrit Hulleman


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message