ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "vikramjit singh" <vikramjit.si...@mphasis.com>
Subject RE: java.lang.InstantiationException: org.apache.tools.ant.Main Using ANT 1.6
Date Thu, 30 Oct 2003 13:08:29 GMT
Hi,

Ok so what i did was, i thought what the heck, remove weblogic.jar from
classpath.
And viola, both ant and weblogic server work fine.
Now i start weblogic server, and i think of shutting it down via ant using
the task wlstop

<wlstop classpath="${weblogic.classes}"
            user="weblogic"
            url="t3://localhost:7001"
            password="weblogic"
            beahome="${BEA_HOME}"/>

weblogic/Admin not found...

I put weblogic.jar in classpath, then it worked, after changing ant_home all
other variables to 1.5.
Why is this problem not there in 1.5. But the classpath problem i can see in
1.6? Just curious :).

Doing some R&D....& testing. :)

Regards,
Vikram.

-----Original Message-----
From: vikramjit singh [mailto:vikramjit.singh@mphasis.com]
Sent: Wednesday, October 30, 2002 5:38 PM
To: Ant Users List
Subject: RE: java.lang.InstantiationException: org.apache.tools.ant.Main
Using ANT 1.6


Hi Antoine,

I extracted the contents of weblogic.jar, and removed the ant folder
completely. Placed the stripped weblogic.jar back, and added it to the
classpath.
My ANT worked fine this time, but weblogic didn't :(.  I know this error is
not of concern in this list...

Reason: Fatal initialization exception
Throwable: weblogic.common.internal.VersioningError: No WebLogic packages
define
d in CLASSPATH

I put the orignal weblogic.jar file back, now weblogic works but ant gives
the same InstantiationException.

I am trying to remove individual files from weblogic...Its gonna be really
painful.

regards,
Vikram.

-----Original Message-----
From: Antoine Levy-Lambert [mailto:antoine@antbuild.com]
Sent: Thursday, October 30, 2003 3:43 PM
To: Ant Users List
Subject: AW: java.lang.InstantiationException: org.apache.tools.ant.Main
Using ANT 1.6


Hi, vikram,

probably weblogic.jar contains ant.
You might want to make yourself a stripped down version of this weblogic.jar
without ant.

Cheers,
Antoine

-----Ursprungliche Nachricht-----
Von: vikramjit singh [mailto:vikramjit.singh@mphasis.com]
Gesendet: Mittwoch, 30. Oktober 2002 09:46
An: Ant Users List
Betreff: RE: java.lang.InstantiationException: org.apache.tools.ant.Main
Using ANT 1.6


Hi Stefan,

u were right, when i completely deleted the classpath, then ant 1.6 worked.
But when i added the classpath again, it again gave the same problem.
And i also did hard disk search to check where ant.jar is, it's there in
many places, but not in jdk/jre directory. I had checked this before too,
had done everything what the manual says :).

To test what value in the classpath is giving the problem, if in my
classpath i add D:\BEA\weblogic700\server\lib\weblogic.jar, then i get the
same error, but when i remove the weblogic.jar from classpath, then it works
fine.

Any reason why adding weblogic.jar in the classpath is the cause of the
error.

thanks,
vikram.



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message