ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "vikramjit singh" <vikramjit.si...@mphasis.com>
Subject RE: java.lang.InstantiationException: org.apache.tools.ant.Main Using ANT 1.6
Date Wed, 30 Oct 2002 12:07:37 GMT
Hi Antoine,

I extracted the contents of weblogic.jar, and removed the ant folder
completely. Placed the stripped weblogic.jar back, and added it to the
classpath.
My ANT worked fine this time, but weblogic didn't :(.  I know this error is
not of concern in this list...

Reason: Fatal initialization exception
Throwable: weblogic.common.internal.VersioningError: No WebLogic packages
define
d in CLASSPATH

I put the orignal weblogic.jar file back, now weblogic works but ant gives
the same InstantiationException.

I am trying to remove individual files from weblogic...Its gonna be really
painful.

regards,
Vikram.

-----Original Message-----
From: Antoine Levy-Lambert [mailto:antoine@antbuild.com]
Sent: Thursday, October 30, 2003 3:43 PM
To: Ant Users List
Subject: AW: java.lang.InstantiationException: org.apache.tools.ant.Main
Using ANT 1.6


Hi, vikram,

probably weblogic.jar contains ant.
You might want to make yourself a stripped down version of this weblogic.jar
without ant.

Cheers,
Antoine

-----Ursprungliche Nachricht-----
Von: vikramjit singh [mailto:vikramjit.singh@mphasis.com]
Gesendet: Mittwoch, 30. Oktober 2002 09:46
An: Ant Users List
Betreff: RE: java.lang.InstantiationException: org.apache.tools.ant.Main
Using ANT 1.6


Hi Stefan,

u were right, when i completely deleted the classpath, then ant 1.6 worked.
But when i added the classpath again, it again gave the same problem.
And i also did hard disk search to check where ant.jar is, it's there in
many places, but not in jdk/jre directory. I had checked this before too,
had done everything what the manual says :).

To test what value in the classpath is giving the problem, if in my
classpath i add D:\BEA\weblogic700\server\lib\weblogic.jar, then i get the
same error, but when i remove the weblogic.jar from classpath, then it works
fine.

Any reason why adding weblogic.jar in the classpath is the cause of the
error.

thanks,
vikram.



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message