ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy-Lambert <anto...@antbuild.com>
Subject AW: java.lang.InstantiationException: org.apache.tools.ant.Main Using ANT 1.6
Date Thu, 30 Oct 2003 10:13:15 GMT
Hi, vikram,

probably weblogic.jar contains ant.
You might want to make yourself a stripped down version of this weblogic.jar
without ant.

Cheers,
Antoine

-----Ursprungliche Nachricht-----
Von: vikramjit singh [mailto:vikramjit.singh@mphasis.com]
Gesendet: Mittwoch, 30. Oktober 2002 09:46
An: Ant Users List
Betreff: RE: java.lang.InstantiationException: org.apache.tools.ant.Main
Using ANT 1.6


Hi Stefan,

u were right, when i completely deleted the classpath, then ant 1.6 worked.
But when i added the classpath again, it again gave the same problem.
And i also did hard disk search to check where ant.jar is, it's there in
many places, but not in jdk/jre directory. I had checked this before too,
had done everything what the manual says :).

To test what value in the classpath is giving the problem, if in my
classpath i add D:\BEA\weblogic700\server\lib\weblogic.jar, then i get the
same error, but when i remove the weblogic.jar from classpath, then it works
fine.

Any reason why adding weblogic.jar in the classpath is the cause of the
error.

thanks,
vikram.



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message