ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique Devienne <DDevie...@lgc.com>
Subject RE: Need help write task:
Date Thu, 23 Oct 2003 19:44:24 GMT
> From: Dan.Crea@milliman.com [mailto:Dan.Crea@milliman.com]
> 
> I am trying to write an ant task but can't seem to get Execute to run my
> command line.  Specifically, it can't find the executable and returns the
> following error:
> 
> Execption thrown: CreateProcess: cvs -n status
> C:/repository/b_code_cleanup/source/clientware/Random/build.xml error=2

That's usually the error you get for the executable not being in the Path...

> If I hard code the path in the
> setExecutable("c:\development\cvs\bin\cvs.exe") then everything works.
> CVS is part of my PATH so I can't seem to figure out why it's not found. I
> also tried setting the environment but this did not help either.

... but you already knew that. Are you really, really sure that CVS is in
your path when run Ant?

As an experienced Ant guy who just a few days ago was stumped because I
wrote net.bf instead of net.sf, I can assure you everyone eventually will
get stuck on a silly error like mine above.

Check your Path, carefully.

Try running <exec executable="cvs" ... /> just above your custom task.

Run with -debug, and study the output slowly. Etc... --DD

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message