ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: Re obsolete xml-apis.jar in ant1.6 [was ant1.6beta2]
Date Fri, 17 Oct 2003 14:29:49 GMT
At 11:52 AM 10/17/2003 +0200, you wrote:
>Hi Jake,
>
>I am not an expert of xml ... so I do not know if there is any good reason
>why we should be distributing this particular version of xml-apis.jar.
>You are right that the xml-apis.jar which is being distributed with ant is
>not the same as the one which is packaged in Xerces Java 2.5.
>
>Cheers,
>
>Antoine

Hi Antoine,

I'd say, let they guys who distribute Xerces be the XML experts and trust 
that if they provide a particular xml-apis.jar with a particular release of 
Xerces2 (in this case, the latest 2.5.0 release), they did it for a reason 
and, unless we have evidence to the contrary, we should use the current 
provided version rather than some arbitrary previous version.

BTW, I've done a diff on the two archives and it seems that there are some 
changes in the following package (although I'm not sure specifically what 
those changes are?)....

javax.xml.parsers *
javax.xml.transform *
javax.xml.transform.stream *
org.w3c.dom.html
org.xml.sax
org.xml.sax.helpers *

* contains classes that didn't exist in the version of xml-apis that 
shipped with Ant-1.6beta2

Looks like the JAXP version is newer and a bunch of other stuff is 
newer.  I *strongly* recommend that the next beta (or final release) of 
Ant-1.6 ship with the updated xml-apis.jar.  It should always match up with 
that of the currently shipped Xerces release (whatever release Ant chooses 
to ship, that is).

Jake


>-----Ursprungliche Nachricht-----
>Von: Jacob Kjome [mailto:hoju@visi.com]
>Gesendet: Freitag, 17. Oktober 2003 07:40
>An: Ant Users List
>Betreff: Re: ant1.6beta2
>
>
>
>I see one issue right away.  The xml-apis.jar which comes with Ant-1.6beta2
>is old.  The file size should be about 121k, not 106k and the folder dates
>inside the archive should be 3/26/2003, not 2/6/2002.  You have
>XercesImpl.jar, version 2.5.0 there, and that is good, but you should take
>the xml-apis.jar from the Xerces-2.5.0 release and distribute it with Ant
>as well, not some older arbitrary release.
>
>Jake
>
>At 01:13 AM 10/17/2003 +0200, you wrote:
> >Hi ant users,
> >
> >ant1.6 beta2 is available for download from  :
> >
> >http://cvs.apache.org/dist/ant/v1.6beta2/
> >
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message