ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brown, Michael (Denver)" <Michael_Br...@jdedwards.com>
Subject RE: AW: AW: two diff't JDKs
Date Mon, 27 Oct 2003 20:22:50 GMT
Erik,

This is usually attributed to a space in the path issue.  If anywhere in
your arguments there is a path with a space then you have to handle that
by quoting the path or using the short name format.  You can find this
in the using the dos command c:>dir /X
	
	       This displays the short names generated for non-8dot3
file
             names.  The format is that of /N with the short name
inserted
             before the long name. If no short name is present, blanks
are
             displayed in its place.

Again, hope this helps.  If it is not the reason then you might want to
get more -debug information and send that out to see what we can do to
help.

Mike B.

-----Original Message-----
From: Erik Price [mailto:profkyne@yahoo.com] 
Sent: Monday, October 27, 2003 1:14 PM
To: Ant Users List
Subject: RE: AW: AW: two diff't JDKs


--- "Brown, Michael (Denver)" <Michael_Brown@jdedwards.com> wrote:
> Erik,
> 
> Glad I could help.  I had one additional note around your separate
> JDK
> compilation:
> 
> We had two solutions because of administration issues on the machine
> where the build will occur:
> 
> 1. If we have control of the machine doing the build, we can set a
> new
> environment variable such as JAVA11_HOME.
> 2. If we don't have control of the machine but have a standard
> location
> in a properties file that can be modified if necessary, we use the
> property file and set a java.1.1.home.
> 
> 
> Mike B.

Thanks, Mike.  I opted for the properties file approach, since my team
will be using my build.xml and build.properties (with the properties
files configured for their specific machines).

Everything seems to work except for one last detail, which appears to
be some kind of inconsistency between Ant and the 1.1.8 compiler (I'm
using ant 1.5.4 per Antoine's suggestion):

When I run the <javac> task, if I set "debug='true'" then I get this
mysterious error:

    [javac] javac: invalid argument:
@C:\newdist\mswp-2a\files1011518451

That's fine, I don't need the debug symbols enabled, but if I remove
the "debug" attribute altogether, then I get this mysterious error:

    [javac] javac: invalid flag: -g:none

Which seems to be a case of the 1.1.8 javac compiler choking on the
command that Ant sends to it when there's no "debug" attribute
specified.  I've also tried changing the value of the "debug" attribute
to things like "none", ":none", "source", and ":source".  I found some
documentation on those arguments at
<http://java.sun.com/j2se/1.3/docs/tooldocs/win32/javac.html>, but
since none of these are really valid values for the "debug" attribute,
the compiler just gives the same error about the invalid "-g:none"
flag.

Does anyone know of a problem with Ant speaking to the 1.1 javac
compiler?


Thanks,

Erik

=====
-- 
Copyright.  Copy right.
The right to copy.  That's all it is.
Contrary to popular belief, there's no such thing as intellectual
"property".

__________________________________
Do you Yahoo!?
Exclusive Video Premiere - Britney Spears
http://launch.yahoo.com/promos/britneyspears/

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message