ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Gordon" <tim.gor...@allustra.com>
Subject RE: problem with the java task...
Date Wed, 03 Sep 2003 16:26:14 GMT
It sounds like it's crashed with no output but the forked JVM hasn't
terminated - ANT will wait to join up with any forked JVM. Don't be fooled
into thinking that ANT will spawn another long-lived JVM and then the ANT
JVM will exit.

Have you tried running in verbose and then executing the command that output
directly, just to ensure the the command line is OK - that way you can
determine whether ANT is the problem or the launched app is.

And finally, the line

                <jvmarg
value="-Djava.naming.provider.url=t3://172.21.113.98:7942 -Xmaxf0.10 -Xms32m
 -Xmx256m"/>

will set the system property java.naming.provider.url to be
"t3://172.21.113.98:7942 -Xmaxf0.10 -Xms32m -Xmx256m", which may be what's
going wrong.

Either split each jvmarg up or use:

                <jvmarg
line="-Djava.naming.provider.url=t3://172.21.113.98:7942 -Xmaxf0.10 -Xms32m 
-Xmx256m"/>

HTH

Tim

-----Original Message-----
From: Laxma.Nandikonda@nokia.com [mailto:Laxma.Nandikonda@nokia.com]
Sent: 03 September 2003 16:00
To: user@ant.apache.org
Subject: problem with the java task...


Hi friends,

 <target name="run" description="runs the application">
          <java classname="com.nokia.platypus.Start"
                failonerror="true"
                fork="yes"
                classpath="${compile_classpath}:${build}">
                <arg value="-pdd ..\conf\oclient_pdd_vc.xml"/>
                <jvmarg value="-Dplatypus.trampoline=false"/>
                <jvmarg value="-Duser.region=GB"/>
                <jvmarg value="-Duser.language=en"/>
                <jvmarg
value="-Dswing.defaultlaf=com.nokia.platypus.nlaf.NokiaLookAndFeel"/>
                <jvmarg
value="-Djava.naming.provider.url=t3://172.21.113.98:7942 -Xmaxf0.10 -Xms32m
 -Xmx256m"/>
                <jvmarg
value="-Djava.naming.factory.initial=weblogic.jndi.WLInitialContextFactory"/
>
                <jvmarg value="-DPlatformHost.IP=localhost"/>
                <jvmarg value="-Dflexlm.licensefile=..\conf\lmdlicmx.dat"/>
          </java>
  </target>


When I run the above target, it goes into executing mode saying "executing
task "run" " and never returns and even sometimes I couldn't cancel it
though I can work with other applications. I am unable to point out what's
the problem is ??. I am just transferring my IDEA environment to a ant build
script file. Though I am running it in verbous mode .. At least I want to
know what's wrong ? How can I debug this situation ?? or is something wrong
with this target ??

Thanks in advance..

lakhsy..


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message