ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Hatton" <khat...@axiomsystems.com>
Subject RE: Performing an Oracle Import using <exec>
Date Wed, 24 Sep 2003 16:03:32 GMT
Is it as simple as the difference between your example users (xyz/xyz1 in the terminal line,
and vgrnb/vgrnb1 in the build script)?

Running ant -verbose or -debug should give you more information on what's actually being executed.


-----Original Message-----
From: Billy Bacon [mailto:billy.bacon@thirty3.net]
Sent: 24 September 2003 16:04
To: Ant Users List
Subject: Performing an Oracle Import using <exec>


I've searched the archives and couldn't find a similar issue so I'm hoping
someone can help me out here...

I'm trying to perform an oracle import with the <exec> command. Here is the
command that I can use from a terminal and will execute fine...

$ORACLE_HOME/bin/imp xyz/xyz1@VGRNB ignore=Y
file=$GKECMS/data/test/voyager-test.dmp log=/tmp/voyager-test-imp.log

I have tried the following with the <exec> command and it's not working
properly... It's exiting with a result of '1'... The oracle error I'm
receiving is that the table or view does not exist. I know this isn't a DBA
user list but I'm wondering if anyone has had this problem before. Is there
a way to print out the entire command as a string to see how Ant is creating
the command? Or am I constructing the arguement line incorrectly? I've tried
individual <arg> tags and I get the same error...


This is my target...

<target name="import.test.data" depends="drop.tables">
    <exec dir="${env.ORACLE_HOME}/bin" executable="imp"
output="/tmp/voyager-test-imp.log">
        <arg line="vgrnb/vgrnb1@VGRNB ignore=Y
file=${gkecms}/data/test/voyager-test.dmp"/>
    </exec>
</target>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message