ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey N. Solofnenko" <A.Solofne...@mdli.com>
Subject Re: Build.xml not working correclty when calling Makefile
Date Wed, 24 Sep 2003 20:35:21 GMT
I think you need to add <exec dir="PGL_JNI" ...> attribute.

- Alexey.

Lindsey, Lucinda wrote:

>Hi,
>
>Our requirements to build our project are simple. We need to create a
>framework directory that all subdirectories are checked out into before they
>can be built using our existing makefiles.  We are new to ant, and our
>attempt at doing this in our build.xml file was not successful. Here's the
>build:
>
>?xml version="1.0" ?>
> <project name="SNL_Tool_Root" default="make">
>  <target name="make">
>  <cvs package="PGL_JNI"></cvs>
>   <exec executable="make">
>        <arg line="-f PGL_JNI/Makefile"/>
>  </exec>
>  </target>
></project>
>
>Although it correctly builds, the log file reveals the following error:
>
>     [exec] Executing 'make' with arguments:
>     [exec] '-f'
>     [exec] 'PGL_JNI/Makefile'
>     [exec] 
>     [exec] The ' characters around the executable and arguments are
>     [exec] not part of the command.
>     [exec] PGL_JNI/Makefile:89: config/version: No such file or directory
>     [exec] make: *** No rule to make target `config/version'.  Stop.
>     [exec] Result: 2[exec] 
>
>When executing the make outside of ant, it builds successfully. We are
>running ant 1.5.4 on Solaris 8 and Java 1.4.1.
>
>Any help is greatly appreciated!
>
>Cindy Lindsey
>Sandia National Labs
>(505)844-0548
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>For additional commands, e-mail: user-help@ant.apache.org
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message