ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "W. Sean Hennessy" <shenne...@goldenhourdata.com>
Subject RE: Different behaviour when running <java> from command line
Date Mon, 22 Sep 2003 17:14:57 GMT
Probably the command line environment different from Ant.bat.
-debug option launching ant will expose the details of the underlying ant environment that
are different from your cmd
line env.
Actual paths, JDKs used..

-----Original Message-----
From: mark stephens [mailto:mark@idrsolutions.com] 
Sent: Monday, September 22, 2003 10:05 AM
To: Ant Users List
Subject: Different behaviour when running <java> from command line


I am running some code which uses RC4 and the JCE jar
(bcprov-jdk14-119.jar) from legionoftheBouncyCastle (what a name!). I am using Java 1.4/Ant
1.6

If I run the code using the command line with 

java -Xms8M -Xmx214M -cp /home/markee/workspace/library/bcprov-jdk14-119.jar:test.jar
org/test/TestCode

it works. However, if I do the same in Ant (same binary, same location)

<java classname="org.test.TestCode" /> 
  <classpath>
    <pathelement location="/home/markee/workspace/library/bcprov-jdk14-119.jar" />
    <pathelement location="test.jar" />
    </classpath>
  </java>

I get an Exception java.security.NoSuchAlgorithmException: Cannot find any provider supporting
RC4 when the program is
running. 

I know it can see bcprov-jdk14-119.jar because if I comment it out, I get an error earlier
in the code when I add the
provider.

Any ideas?? 

MArk


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message