ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Levy-Lambert" <anto...@antbuild.com>
Subject Re: problem with the java task...
Date Wed, 03 Sep 2003 16:09:42 GMT
Hi Laxma,

I suppose the Java application that you want to start with the <java/> task
is really a kind of background process or server running permanently.
With ant 1.5, you can use parallel to do other activities in ant while your
application server is being started and run, or you can use the exec task
and a shell-script wrapper to start your java program.

With ant 1.6alpha, the java task has a spawn attribute with which you can
say : I want this process to run in background.

Cheers,

Antoine
----- Original Message -----
From: <Laxma.Nandikonda@nokia.com>
To: <user@ant.apache.org>
Sent: Wednesday, September 03, 2003 5:00 PM
Subject: problem with the java task...


Hi friends,

 <target name="run" description="runs the application">
          <java classname="com.nokia.platypus.Start"
                failonerror="true"
                fork="yes"
                classpath="${compile_classpath}:${build}">
                <arg value="-pdd ..\conf\oclient_pdd_vc.xml"/>
                <jvmarg value="-Dplatypus.trampoline=false"/>
                <jvmarg value="-Duser.region=GB"/>
                <jvmarg value="-Duser.language=en"/>
                <jvmarg
value="-Dswing.defaultlaf=com.nokia.platypus.nlaf.NokiaLookAndFeel"/>
                <jvmarg
value="-Djava.naming.provider.url=t3://172.21.113.98:7942 -Xmaxf0.10 -Xms32m
 -Xmx256m"/>
                <jvmarg
value="-Djava.naming.factory.initial=weblogic.jndi.WLInitialContextFactory"/
>
                <jvmarg value="-DPlatformHost.IP=localhost"/>
                <jvmarg value="-Dflexlm.licensefile=..\conf\lmdlicmx.dat"/>
          </java>
  </target>


When I run the above target, it goes into executing mode saying "executing
task "run" " and never returns and even sometimes I couldn't cancel it
though I can work with other applications. I am unable to point out what's
the problem is ??. I am just transferring my IDEA environment to a ant build
script file. Though I am running it in verbous mode .. At least I want to
know what's wrong ? How can I debug this situation ?? or is something wrong
with this target ??

Thanks in advance..

lakhsy..


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message