ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <>
Subject Re: 1.5 branch still uses in
Date Mon, 18 Aug 2003 06:52:07 GMT
On Sat, 16 Aug 2003, Trevor Harmon <> wrote:

> This can easily be fixed by downloading and installing IBM's version
> of BSF. However, this prevents me from using "beanshell" as my
> scripting language because Beanshell's jar references
> org.apache.bsf, not

You'll have to use an older version of beanshell as well and things
should work.

> Unfortunately, this important change has not been backported to the
> 1.5 branch.

Because we intend to remain fully backwards compatible within minor
release series as opposed to reasonably backwards compatible 8-)

Current CVS has swapped IBM's BSF for Apache's as well as ORO's
netcomponents for the jakarta-commons version.

> I hope that the next 1.5.x release will contain the 1.19 patch to

There probably won't be any next 1.5.x release and even if there was,
it is pretty unlikely (I'd say impossible) that the change is going to
be merged.

> Until then, I am having to run unstable development versions of Ant
> or patch and recompile the source code myself.

or instead use an older and released version of beanshell.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message